gildot

Topo
Sobre
FAQ
Tópicos
Autores
Preferências
Artigos
Sondagens
Propor artigo


8/3
gildicas
9/30
jobs
10/9
perguntas
10/25
press

 
Site da DGCI a 95%
Contribuído por Xmal em 06-04-04 10:28
do departamento not-yet-100%
Portugal Passado um ano sobre este artigo, o site da DGCI continua a ser uma boa experiência de navegação com um interface simples e compatível, com uso de PDFs para os documentos e suporte para multiplos sistemas operativos na entrega das declarações electrónicas. É um bom e raro exemplo de um bom interface com o cidadão, que não força escolhas e permite a diversidade e acessibilidade.
Contudo, lá num cantinho resiste o simulador de IRS, que para correr online requer Internet Explorer e para correr offline só no sistema operativo dominante.
Já mandei um mail para a DGITA a indicar a questão, e aconselho os demais contribuntes que usam plataformas "alternativas" a fazer o mesmo.

WiX: Primeiro Projecto Open Source da Microsoft | Google X Privacidade  >

 

gildot Login
Login:

Password:

Referências
  • DGITA a indicar a questão, e aconselho os demais contribuntes que usam plataformas "alternativas" a fazer o mesmo. Passado um ano sobre este artigo
  • DGCI
  • num cantinho
  • Mais acerca Portugal
  • Também por Xmal
  • Esta discussão foi arquivada. Não se pode acrescentar nenhum comentário.
    Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 11:13 GMT (#1)
    (Utilizador Info)
    que não força escolhas e permite a diversidade e acessibilidade.
    Para além de haver declarações de IRS que são forçadas a ser feitas on-line, é necessário suporte a Java:
    -> depende de JVM proprietárias logo força escolha.
    -> java applets e acessibilidade? Pois pois...
    Re:Bzzt! Wrong! (Pontos:2)
    por Psiwar em 06-04-04 11:29 GMT (#3)
    (Utilizador Info) http://www.netcode.pt
    Olha que já tem um form em HTML...
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 11:58 GMT (#7)
    (Utilizador Info)
    Para preenchimento completo dos dados de forma on-line? Se sim espetacular, excelentes notícias. Ainda devo ir a tempo de utilizar.
    Re:Bzzt! Wrong! (Pontos:2)
    por jadrian em 06-04-04 13:33 GMT (#20)
    (Utilizador Info)
    Confirmo, existe.
    Bzzt! Wrong!(Bzzt! Wrong!)==nil (Pontos:2)
    por Xmal em 06-04-04 11:34 GMT (#4)
    (Utilizador Info) http://gsd.di.uminho.pt/cbm
    Nunca iremos concordar neste aspecto mas não deixo de respeitar essa opinião.

    No que me respeita não vejo um problema grave em correr software proprietario, desde que os dados sejam guardados em formatos estáveis, com especificações públicas e sem restrições à construção de software de leitura alternativo.

    Perante alternativas viáveis free software ou open source a opções proprietárias opto pelas primeiras, mas não é meramente por isso que passo a achar que não se permite diversidade e acessibilidade.

    Não vale a pena entrarmos numa espiral sobre isto pois nunca nos vamos convencer mutuamente ;)

    Re:Bzzt! Wrong!(Bzzt! Wrong!)==nil (Pontos:2)
    por Cyclops em 06-04-04 11:59 GMT (#8)
    (Utilizador Info)
    No que me respeita não vejo um problema grave em correr software proprietario, desde que os dados sejam guardados em formatos estáveis, com especificações públicas e sem restrições à construção de software de leitura alternativo.
    Mas não é isto que acontece (ou acontecia se o que o Psiwar disse se concretizar). Embora haja um formato "documentado" depois como é que o envias? -> dantes era com um applet.

    Logo estás _forçado_ a utilizar software proprietário.
    Re:Bzzt! Wrong! (Pontos:2)
    por CrLf em 06-04-04 11:43 GMT (#5)
    (Utilizador Info) http://crodrigues.webhop.net
    depende de JVM proprietárias logo força escolha

    Sinceramente, preferias o quê? Que fosse feito em Javascript e só corresse no IE?

    -- Carlos Rodrigues
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 12:01 GMT (#9)
    (Utilizador Info)
    Não. Que fosse feito de acordo com vários standards oficiais, tal como ECMAScript (JavaScript é uma implementação fiel de ECMAScript, ao contrário do JScript da Microsoft, este sim só funciona no IE em muitas funções), DOM (que normalmente os sites "feitos para IE" não respeitam), (X)HTML, CSS, etc...

    Assim a única culpa de não funcionar seriam bugs do software.
    Re:Bzzt! Wrong! (Pontos:2)
    por CrLf em 06-04-04 12:11 GMT (#10)
    (Utilizador Info) http://crodrigues.webhop.net
    Pois, decerto sabes que as implementações variam muito entre os browsers e que fazer aplicações web usando Javascript, mesmo que seguindo o standard, é pedir problemas. A implementação do ECMAScript não é igual em todo o lado, bem como a de DOM. Pelo menos em Java sabe-se que corre bem em qualquer lado sem ser preciso andar a fazer milhentos casos especiais (e além de que consegue correr como aplicação independente, o que é bom).

    -- Carlos Rodrigues
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 12:17 GMT (#11)
    (Utilizador Info)
    mesmo que seguindo o standard, é pedir problemas. A implementação do ECMAScript não é igual em todo o lado, bem como a de DOM.
    Se seguindo o standard há problemas, então os problemas são bugs do software. Ajuda a corrigi-los, ou a licença deles não te dá as liberdades necessárias para o fazer?

    Pelo menos em Java sabe-se que corre bem em qualquer lado sem ser preciso andar a fazer milhentos casos especiais
    LOL. Mesmo onde não corra por qualquer motivo, tal como não existir VM para ess arquitectura ou a pessoa não concordar com a licença?

    standards da web, a sua má implementação da parte de algum software não é desculpa para incompetência técnica de quem faz sites.
    Re:Bzzt! Wrong! (Pontos:2)
    por CrLf em 06-04-04 12:39 GMT (#12)
    (Utilizador Info) http://crodrigues.webhop.net
    Se seguindo o standard há problemas, então os problemas são bugs do software. Ajuda a corrigi-los, ou a licença deles não te dá as liberdades necessárias para o fazer?

    Ok, I'll bite... Não, nem a licença do Opera, nem a do IE me dão a liberdade para o fazer. E eu dou preferência a uma solução que funcione também nestes, para além de funcionar nos browsers opensource tipo o Mozilla ou Konqueror. Se eu não concordo com práticas discriminatórias do tipo IE-only também não concordo com práticas tipo Mozilla-only. Interoperabilidade primeiro, licença depois.

    LOL. Mesmo onde não corra por qualquer motivo, tal como não existir VM para ess arquitectura ou a pessoa não concordar com a licença?

    Há VMs para uma porrada de arquitecturas, diria até que para quase tantas onde existe Mozilla ou Konqueror. Não concordar com a licença é problema de quem não concorda, o Java é software aberto e não estou a ver que condições impõe ao utilizador que o leve a recusá-lo.

    Há standards da web, a sua má implementação da parte de algum software não é desculpa para incompetência técnica de quem faz sites.

    Incompetência é quando fazem sites que só funcionam num browser, discriminando aqueles que não o querem usar ou não o podem usar, e quando ignoram as queixas justificando-se com a lenga-lenga dos 90% (porra, até a Microsoft corrige problemas do seu site relacionados com o Mozilla -- bem, na parte do Windows Services for UNIX pelo menos :)). O facto de terem escolhido uma solução multiplataforma (como até é demonstrado pelo facto de disponibilizarem versões afinadas para vários SOs, incluíndo o Solaris) e multibrowser só demonstra o contrário de incompetência.

    -- Carlos Rodrigues
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 13:06 GMT (#13)
    (Utilizador Info)
    Se eu não concordo com práticas discriminatórias do tipo IE-only também não concordo com práticas tipo Mozilla-only. Interoperabilidade primeiro, licença depois.
    Fazer sites de acordo com os standards não é uma prática discriminatória má. Aumentas o potencial de audiência e promoves a qualidade do software.

    Fazer sites de acordo com os standards não os torna Mozilla-only (o que também seria mau). Se queres apoiar a interoperabilidade deverias apoiar que se utilizassem os standards, pois só assim se consegue obter interoperabilidade. Os bugs resolvem-se.

    Há VMs para uma porrada de arquitecturas, diria até que para quase tantas onde existe Mozilla ou Konqueror.
    O que te impede de portar o Mozilla ou Konqueror para uma arquitectura onde não existam? A tua capacidade técnica.
    O que te impede de portar a JVM para uma arquitectura onde não exista? Antes de sequer poderes falar da tua capacidade técnica tens a licença.

    Não concordar com a licença é problema de quem não concorda, o Java é software aberto e não estou a ver que condições impõe ao utilizador que o leve a recusá-lo.
    Wow! Para aí os cavalos! Acabaste de dizer uma enorme asneira. Java é uma linguagem de programação "patent encumbered". Nenhuma JVM capaz é Livre, e há muito receio de ao fazer uma Livre que possa competir se tornem vítimas da Sun.

    Da forma como a Sun tem estado a morrer, eu prefiro não correr o risco de me tornar vítima dos advogados deles.

    Se não vez que condições impõe a licença deles que me leva a não concordar com ela, então procura a resposta a estas 4 perguntas. Se a resposta for sim a todas, então estaria em condições de concordar:
    1. posso correr a jvm para qualquer fim?
    2. posso estudar a JVM e adaptá-la às necessidades?
    3. posso distribuir cópias da JVM?
    4. posso publicar versões melhoradas da JVM?

    Qualquer não a estas três perguntas implica que a licença não respeita direitos que considero que devo no mínimo ter. Logo não poderia concordar com a licença.

    Incompetência é quando fazem sites que só funcionam num browser
    Isso _também_ é incompetência, mas de quem? Se o site estiver feito 100% de acordo com os standards, é provavel que seja bug do browser ou pura e simplesmente incompetência do seu fornecedor :)

    Se fizeres um site de acordo com os standards da web funciona-te muito bem nos últimos IEs... (terá sido da concorrência do Mozilla?)
    Re:Bzzt! Wrong! (Pontos:2)
    por CrLf em 06-04-04 13:25 GMT (#17)
    (Utilizador Info) http://crodrigues.webhop.net
    Fazer sites de acordo com os standards não é uma prática discriminatória má. Aumentas o potencial de audiência e promoves a qualidade do software.
    Fazer sites de acordo com os standards não os torna Mozilla-only (o que também seria mau). Se queres apoiar a interoperabilidade deverias apoiar que se utilizassem os standards, pois só assim se consegue obter interoperabilidade. Os bugs resolvem-se.


    Pois claro, mas tu queres tudo de uma vez. Um standard não se impõe, caminha-se para ele.
    Neste momento o standard ainda não domina, não há implementações que o cumpram a 100% nem sequer as que o cumprem melhor são generalizadas, portanto o melhor a fazer é caminhar devagar. Se tentares impor standards à força só vais conseguir que sejam ignorados a favor daqueles que não são verdadeiros standards mas são muito usados. Por alguma razão o Mozilla, por exemplo, inclui um modo amigo dos standards e outro que come html estragado muito ao bom estilo do IE.

    Se não vez que condições impõe a licença deles que me leva a não concordar com ela, então procura a resposta a estas 4 perguntas. Se a resposta for sim a todas, então estaria em condições de concordar:
    1. posso correr a jvm para qualquer fim?
    2. posso estudar a JVM e adaptá-la às necessidades?
    3. posso distribuir cópias da JVM?
    4. posso publicar versões melhoradas da JVM?

    E é exactamente aqui que está o ponto em que discordamos. Eu não sou contra o software proprietário em si, mas sim contra o software proprietário que segue uma via de anti-interoperabilidade (software proprietário vs. formatos proprietários). Portanto para mim essas quatro liberdades são uma forma de premiar o software e não uma checklist que me leve a recusá-lo. Eu prefiro software livre mas não sou contra o software proprietário (apenas contra aquele que me prende aos seus formatos proprietários). Eu decido caso-a-caso e não segundo regras dogmáticas.

    -- Carlos Rodrigues
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 15:55 GMT (#33)
    (Utilizador Info)
    Um standard não se impõe, caminha-se para ele.
    Acho que precisas de aulas de história. Tu estás a defender que não se devem fazer as coisas segundo standards porque há aplicações que não os seguem.
    Muito bem. Então a) porque é que te esqueces que essas aplicações estão a ser usadas intencionalmente pelos autores para proliferar o seu monopólio (logo os standards é melhor não cumprir), b) quem está a impor alguma coisa é quem não segue o standard, apesar de ser um elemento fundamental do working group.

    Neste momento o standard ainda não domina, não há implementações que o cumpram a 100%
    Não domina por falta de vontade de um membro do working group (a Microsoft) e por incompetência das entidade que criam sites que têm de se ver em IEs que não suportam os standards.

    nem sequer as que o cumprem melhor são generalizadas, portanto o melhor a fazer é caminhar devagar.
    Tipo, desde mil novecentos e troca o passo? Mais devagar e provavelmente os caracois e lesmas passam à frente!

    Por alguma razão o Mozilla, por exemplo, inclui um modo amigo dos standards e outro que come html estragado muito ao bom estilo do IE.
    Pois, com tantos "bugs" falsos de páginas que não se viam bem, quando a culpa era do mau código, tiveram de desperdiçar muitos homens/mês a tentar compensar o melhor possível a ignorância/incompetência de muitos.
    Re:Bzzt! Wrong! (Pontos:2)
    por CrLf em 07-04-04 0:36 GMT (#66)
    (Utilizador Info) http://crodrigues.webhop.net
    Tu estás a defender que não se devem fazer as coisas segundo standards porque há aplicações que não os seguem.

    Errado, eu estou a defender que os standards não devem ser impostos como uma sentença mas sim incentivados, caso contrário as pessoas rejeitá-los-ão rapidamente a favor de outros "standards" mais simpáticos. A minha via é convencer, a tua é obrigar e ninguém gosta de ser obrigado.

    Tipo, desde mil novecentos e troca o passo? Mais devagar e provavelmente os caracois e lesmas passam à frente!

    Como se costuma dizer, o que é bom nos standards é que há tantos... Há uma data de anos que se sucedem os standards sem que o anterior se tenha realmente tornado um. Isto é terreno propício para os standards de facto e é isto que tem vindo a acontecer. Numa situação destas só consegues impor um standard interoperável se ele for "infectando" lentamente os pseudo-standards existentes. Usa uma táctica de choque e garantidamente a infecção é terminada e aquilo que queres vencer torna-se invencível. Não te esqueças que é um movimento que parte de uma minoria...

    -- Carlos Rodrigues
    Re:Bzzt! Wrong! (Pontos:1)
    por edsonmedina em 06-04-04 18:13 GMT (#38)
    (Utilizador Info)
    Se tentares impor standards à força só vais conseguir que sejam ignorados a favor daqueles que não são verdadeiros standards mas são muito usados.

    Não. É mais o contrário.

    Se o pessoal continuar a fazer HTML IE-only o standard nunca será adoptado, e a Microsoft agradece.
    Re:Bzzt! Wrong! (Pontos:1)
    por edsonmedina em 06-04-04 18:08 GMT (#37)
    (Utilizador Info)
    Se eu não concordo com práticas discriminatórias do tipo IE-only também não concordo com práticas tipo Mozilla-only.

    Não é uma questão de Mozilla-only. É mais uma questão de "standards compliant only".

    Interoperabilidade primeiro, licença depois.

    Interoperabilidade primeiro???!! Tás a gozar.
    A unica maneira de garantires isso na web é com XHTML puro e duro, com tags de acessibilidade e SEM Java/Javascript (não funcionam "muito bem" no meu lynx / PDA / WebTV / telemóvel / whatever).
    Não é com Java que me garantes a interoperabilidade de certeza.

    Licença depois???? Amigo, a licença TEM DE ESTAR ACIMA DE TUDO!

    NINGUÉM deve ser obrigado a usar tecnologias proprietárias (nem que seja pelo facto de estar a benefeciar os bolsos de uma firma privada) para preencher a porcaria do IRS.
    Re:Bzzt! Wrong! (Pontos:2, Esclarecedor)
    por joaorf em 06-04-04 13:18 GMT (#15)
    (Utilizador Info)
    Sinceramente já cansa a tua cruzada anti-Java. Com tantos sites que os utilizadores de Linux não conseguem visualizar correctamente (ou não conseguem entrar mesmo!) e com o crescente disponibilização de conteúdo que faz uso de codecs multimedia não-interoperáveis como Windows Media e Sorenson, tu eleges como "grande problema" o facto de haverem sites que têm applets de Java!

    É preciso seleccionar prioridades. A falta de interoperabilidade é muito mais grave do que o facto de não ser GPL. Atacar o uso de Java é uma péssima escolha de prioridades.

    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 15:41 GMT (#31)
    (Utilizador Info)
    A falta de interoperabilidade é muito mais grave do que o facto de não ser GPL.
    Concordo que a falta de interoperabilidade é muito grave, mas não percebo o que é que ser ou não GPL tem a ver com o assunto. Estou a falar de Software Livre e não da licença GPL em particular.

    Atacar o uso de Java é uma péssima escolha de prioridades.
    Java == 0 de interoperabilidade.

    Standards abertos == interoperabilidade.

    Chiça!
    Re:Bzzt! Wrong! (Pontos:2)
    por [Cliff] em 06-04-04 15:50 GMT (#32)
    (Utilizador Info) http://www.yimports.com
    Engraçado... uma das mais valias do Java é a interoperabilidade de sistemas :| Oh well, dezenas de engenheiros estão errados, o Cyclops é que tem razão :)

    ---
    Conformity is the jailer of freedom and the enemy of growth.
    --John F. Kennedy
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 17:23 GMT (#36)
    (Utilizador Info)
    Não. Uma das [supostas] mais valias do Java é write once, run everywhere. Ora, write once, ainda vá que não vá, mas run everywhere... basta que alguem utilize JNI e a coisa já não é linear.

    Interoperabilidade era eu pegar numa JVM _qualquer_ e conseguir utilizar perfeitamente as classes da JVM da Sun e vice versa.

    As dezenas de engenheiros tinham um sonho que tinha valor, mas a Sun e os interesses comerciais da Sun deram cabo dele. Estás a confundir a interoperabilidade.

    Se achas assim tão interoperável... porque não mudas toda a UI do Sapo para Java?
    Re:Bzzt! Wrong! (Pontos:2)
    por [Cliff] em 06-04-04 18:18 GMT (#39)
    (Utilizador Info) http://www.yimports.com
    Porque não faço desenvolvimento no Sapo :) Fala com o responsável técnico daquilo.

    ---
    Conformity is the jailer of freedom and the enemy of growth.
    --John F. Kennedy
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 06-04-04 18:36 GMT (#40)
    (Utilizador Info)
    Força de expressão.

    Faz no yimports que aí já não tens de falar com o responsável técnico ]:->
    Re:Bzzt! Wrong! (Pontos:2)
    por [Cliff] em 06-04-04 19:20 GMT (#49)
    (Utilizador Info) http://www.yimports.com
    lol no way josé! :P Aquilo quase nem é suposto existir. É um legacy domain que só serve para o email :-S wanna buy? ;-)

    ---
    Conformity is the jailer of freedom and the enemy of growth.
    --John F. Kennedy
    Re:Bzzt! Wrong! (Pontos:2)
    por joaorf em 06-04-04 23:49 GMT (#65)
    (Utilizador Info)
    Se achas assim tão interoperável... porque não mudas toda a UI do Sapo para Java?

    Porque um jipe não é o veículo mais apropriado para provas de velocidade em asfalto, e um Ferrari não é o veículo mais adequado para o Paris-Dakar...

    mais uma vitima da publicidade (Pontos:2, Esclarecedor)
    por edsonmedina em 06-04-04 18:42 GMT (#45)
    (Utilizador Info)
    Engraçado... uma das mais valias do Java é a interoperabilidade de sistemas

    Marketing e realidade nem sempre andam juntos.


    Re:Bzzt! Wrong! (Pontos:1)
    por coder em 06-04-04 18:42 GMT (#44)
    (Utilizador Info)
    Java == 0 de interoperabilidade

    em C isso é um teste de uma condição... cujo resultado é FALSO.

    Re:Bzzt! Wrong! (Pontos:1)
    por edsonmedina em 06-04-04 18:38 GMT (#42)
    (Utilizador Info)
    Sinceramente já cansa a tua cruzada anti-Java.

    A mim parece-me mais uma cruzada anti-monopólios, mas quem não quer ver não vê mesmo.

    Com tantos sites que os utilizadores de Linux não conseguem visualizar correctamente (ou não conseguem entrar mesmo!) e com o crescente disponibilização de conteúdo que faz uso de codecs multimedia não-interoperáveis como Windows Media e Sorenson, tu eleges como "grande problema" o facto de haverem sites que têm applets de Java!

    Phear. Pá, nem sei por onde começar...

    <flame>
    Os applets de Java na web são tipo a pior merda que se inventou desde... sei lá... não encontro uma metáfora suficientemente forte para descrever isso.

    Exemplos:

    * over-buttons em java

    hihihi, são do melhor que há na web, na maioria das vezes crasham-me o browser

    * scrollers em java

    Outra magnifica invenção, são a melhor maneira de se gastarem 60 Megas de memória. Não usem javascript, deixem estar assim que tá melhor.

    * menus
    * galerias de imagens
    * imagens animadas (ahahha, venha lá a compuserve e os seus gifs)
    ...

    bla bla bla

    Tens bons exemplos de utilidades para essa merda? Isto é, para além de me lembrar que tenho de tirar uma pausa (porque o browser crashou).

    Não vamos falar do tempo que leva a carregar, nem do facto da área da applet ter um comportamento diferente do resto da página.

    Usabilidade? O que é isso?
    </flame>

    A falta de interoperabilidade é muito mais grave do que o facto de não ser GPL.

    Java não é nem uma coisa nem outra.


    Re:Bzzt! Wrong! (Pontos:0, Despropositado)
    por coder em 06-04-04 18:40 GMT (#43)
    (Utilizador Info)
    és um completo ignorante
    ena, mais um esperto (Pontos:1)
    por edsonmedina em 06-04-04 20:32 GMT (#57)
    (Utilizador Info)
    és um completo ignorante

    E tu tens umas respostas muito elaboradas. Tens tens...

    Talvez eu não seja assim tão ignorante. Talvez até já cá ande há alguns dias.

    Felicite-me com os seus contra-argumentos por favor, Sr.Dr.
    Re:Bzzt! Wrong! (Pontos:1, Despropositado)
    por joaorf em 06-04-04 19:52 GMT (#50)
    (Utilizador Info)
    Troll...
    Re:Bzzt! Wrong! (Pontos:1)
    por edsonmedina em 06-04-04 20:26 GMT (#53)
    (Utilizador Info)
    Vais gritar "Troll" em todos os meus posts?

    Ou vais responder com argumentos válidos?

    Pera... esquece... não tens argumentos válidos. :)

    Gostas de java e acabou-se. É isso.
    Re:Bzzt! Wrong! (Pontos:2)
    por joaorf em 06-04-04 20:32 GMT (#56)
    (Utilizador Info)
    Mas eu não li argumentos nenhuns desse lado.
    Além disso, só gasto mais de 1 minuto a responder a quem tiver um QI superior a 90...
    Re:Bzzt! Wrong! (Pontos:1)
    por edsonmedina em 06-04-04 22:11 GMT (#60)
    (Utilizador Info)
    Além disso, só gasto mais de 1 minuto a responder a quem tiver um QI superior a 90...

    Ah, então deves ter muitos amigos que usam java.

    ahahahha

    Tudo malta com quoficientes de inteligência na ordem dos 1200... DPI's

    Re:Bzzt! Wrong! (Pontos:2)
    por CrLf em 07-04-04 1:13 GMT (#67)
    (Utilizador Info) http://crodrigues.webhop.net
    Ouve lá, por acaso não estarás a tentar tirar a beca ao tonidosimpostos, não?

    -- Carlos Rodrigues
    Re:Bzzt! Wrong! (Pontos:2)
    por chbm em 07-04-04 22:28 GMT (#75)
    (Utilizador Info) http://chbm.net/
    Perá lá, mas não acabaste de te queixar que a versão HTML não é funcional ? Organiza-te rapaz, tas a discutir contigo próprio e o pior - a perder.
    Re:Bzzt! Wrong! (Pontos:1)
    por henrique em 06-04-04 20:22 GMT (#52)
    (Utilizador Info)
    Estranho não ter encontrado o nome Cyclops nesta lista.
    Re:Bzzt! Wrong! (Pontos:2)
    por MacLeod em 07-04-04 10:21 GMT (#70)
    (Utilizador Info)
    Se vires bem, o Mullah Omar só tem um olho, logo pode ser considerado um Ciclope (ou Cyclops).
    Re:Bzzt! Wrong! (Pontos:2)
    por Cyclops em 07-04-04 11:56 GMT (#73)
    (Utilizador Info)
    Considero bastante ofensivo qualquer analogia com terrorismo. Não passa de uma forma dissimulada de tentar fazer calar outras pessoas, e um desrespeito pela liberdade de expressão delas.
    Mas eu uso superior (Pontos:2, Despropositado)
    por mlopes em 06-04-04 11:26 GMT (#2)
    (Utilizador Info)
    Lá diz que tem que se ter Internet Explorer 4.0 ou superior... humm... mas eu uso superior, mesmo que fosse o IE 6 eu uso superior.... e mesmo assim não funciona! Estranho, será que quem escreveu aquilo sabe o que quer dizer superior?

    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

    :)

    "Para mim a tecnologia é como as tangerinas, na medida em que não consigo fazer uma analogia decente sobre nenhuma das duas neste momento" Scott Adams

    Relíquia (Pontos:2, Informativo)
    por CrLf em 06-04-04 11:44 GMT (#6)
    (Utilizador Info) http://crodrigues.webhop.net
    Segundo sei a applet também faz simulação, portanto o simulador é mais uma relíquia do que outra coisa.

    -- Carlos Rodrigues
    Re:Relíquia (Pontos:2)
    por joaorf em 06-04-04 13:20 GMT (#16)
    (Utilizador Info)
    É verdade. Do ponto de vista do utilizador, o "simulador" já é desnecessário porque o applet de "entrega" já faz simulação. Acredito que eles até o removam do site futuramente.
    Re:Relíquia (Pontos:2)
    por chbm em 07-04-04 22:32 GMT (#76)
    (Utilizador Info) http://chbm.net/
    Sim, o simulador é só mais um sitio parvo para meter os dados todos novamente. blah.
    Então o problema é meu...? (Pontos:2)
    por DomusOnline em 06-04-04 13:15 GMT (#14)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    Pelos comentários fico com a ideia que conseguiram usar a applet em Linux.

    Eu não! O problema está na função de validação do Java... Aquilo tem uma Applet (de nome - name="Checker") e depois em JS invoca um método desta applet... No meu mozilla essa ivocação dá erro (JS).

    Ninguém teve este problema? O meu Mozilla tá velho... 1.3! Será disso?

    Obrigado e cumprimentos.
    Re:Então o problema é meu...? (Pontos:2)
    por CrLf em 06-04-04 13:33 GMT (#19)
    (Utilizador Info) http://crodrigues.webhop.net
    O meu Mozilla tá velho... 1.3! Será disso?

    Eu pessoalmente ainda não experimentei mas já tive conhecimento de casos de sucesso. Provavelmente é mesmo do teu mozilla, até há pouco tempo penso que havia uns problemas relacionados com o Javascript a chamar métodos de Java (tal como acontecia com o flash) por causa de diferenças das bibliotecas usadas para compilar a JVM e o Mozilla.

    -- Carlos Rodrigues
    Re:Então o problema é meu...? (Pontos:2)
    por DomusOnline em 06-04-04 13:39 GMT (#21)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    Desenrasquei-me com o IE, mas ainda vou tentar perceber o problema. Se tiver novidades aviso.

    Cumprimentos.
    Re:Então o problema é meu...? (Pontos:2)
    por joaorf em 06-04-04 14:16 GMT (#25)
    (Utilizador Info)
    Derrotista... :-P
    IE é a última, derradeira opção, quando todas as alternativas estiverem esgotadas.
    Re:Então o problema é meu...? (Pontos:1)
    por edsonmedina em 06-04-04 18:47 GMT (#47)
    (Utilizador Info)
    IE é a última, derradeira opção, quando todas as alternativas estiverem esgotadas.

    Eu normalmente desisto quando não funciona nos outros. IE nunca!
    Re:Então o problema é meu...? (Pontos:2)
    por DomusOnline em 07-04-04 2:52 GMT (#68)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    Eu tenho acesso corrente ao IE... e trata-se do IRS... havia que resolver o meu problema. Quanto ao problema vai noutro post.

    Cumprimentos.
    Re:Então o problema é meu...? (Pontos:2)
    por DomusOnline em 07-04-04 3:02 GMT (#69)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    Bom, e as novidades são que com o Mozilla 1.6 compilado com gcc3.2 deu-me o mesmíssimo erro...

    Algo como:

    Error: parent.main.document.Checker.checkVersion is not a function
    Source File: https://www.e-financas.gov.pt/de/jsp-dgci/main.jsp
    Line: 604

    que se traduz em:

    function submitModoJava(){
    if (!navigator.javaEnabled() || (typeof parent.main.document.Checker == 'undefined')) {
    alert("O Browser utilizado não permite a execução de aplicações Java.\n"+ "Para poder utilizar esta opção deverá efectuar a instalação da "+ "Sun Virtual Machine (Java Plugin).");
    return;
    }
    if(!parent.main.document.Checker.checkVersion()) {
    if (confirm("Para poder utilizar esta opção deverá efectuar a instalação da "+ "Sun Virtual Machine 1.4.2 (Java Plugin).\n"+ "Deseja efectuar o download agora?"))
    janelaAjuda('../ajuda/DGCI/FAQJVM.htm');
    return;
    }
    document.entregaIRSModoJava.submit();
    }

    Alguma ideia? A documentação ue vi de JS não indica que isto se possa fazer. Mas vi numa bastante antiga.

    NOTA: "Checker" é um "name" de uma Applet Java.

    Cumprimentos.
    Re:Então o problema é meu...? (Pontos:2)
    por joaorf em 08-04-04 13:58 GMT (#79)
    (Utilizador Info)
    E com que versão de Java?
    Escreve about:plugins na barra de endereço do Mozilla e diz-me que versão do Java aparece listada.
    Re:Então o problema é meu...? (Pontos:2)
    por DomusOnline em 08-04-04 20:11 GMT (#81)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    A correcta... 1.4.2 Mas isso eu actualizei... Não tive ainda tempo de testar. Não sei se será o Java que não funciona ou problema do JS ou da ligação entre ambos... Mas nem me ficou claro se aquela forma de invocar um método Java via JS é válida...

    Cumprimentos.
    ahahhaha (Pontos:1)
    por edsonmedina em 06-04-04 18:45 GMT (#46)
    (Utilizador Info)
    penso que havia uns problemas relacionados com o Javascript a chamar métodos de Java (tal como acontecia com o flash) por causa de diferenças das bibliotecas usadas para compilar a JVM e o Mozilla.

    É por causa da tal "interoperabilidade" de que falavas.

    Não te esqueças: "Write once, run everywhere". :)

    Re:ahahhaha (Pontos:2)
    por joaorf em 06-04-04 19:54 GMT (#51)
    (Utilizador Info)
    Alguém é capaz de por uma rolha neste troll?
    Re:ahahhaha (Pontos:2)
    por CrLf em 06-04-04 21:58 GMT (#58)
    (Utilizador Info) http://crodrigues.webhop.net
    Deves ser parvo. O que é que ter problemas em chamadas de métodos Java a partir de Javascript por causa de terem sido linkados com libstdc++ diferentes tem a ver com interoperabilidade?

    -- Carlos Rodrigues
    Re:ahahhaha (Pontos:1)
    por edsonmedina em 06-04-04 22:26 GMT (#61)
    (Utilizador Info)
    Deves ser parvo. O que é que ter problemas em chamadas de métodos Java a partir de Javascript por causa de terem sido linkados com libstdc++ diferentes tem a ver com interoperabilidade?

    O ponto é que essa pseudo-interoperabilidade é um "bocadinho" frágil.

    Re:ahahhaha (Pontos:2)
    por Castanheiro em 06-04-04 22:53 GMT (#64)
    (Utilizador Info) http://students.fct.unl.pt/users/fdc10056
    Sinceramente, este thread já tresanda a fundamentalismo.......
    Mas o que é que a interoperabilidade do java tem a ver com um "bug" do mozilla??? O konqueror tem alguns problemas a fazer rendering de algum codigo HTML perfeitamente válido... se calhar é o HTML que tem problemas de "interoperabilidade" !! Vamos todos fazer uma manifestação anti-html!! Vamos portar tudo para dotNET, que esse sim, será duma portabilidade extrema!
    sinceramente.... este thread é digno de um qq lider radical islamico...

    Castanheiro
    Re:ahahhaha (Pontos:2)
    por chbm em 07-04-04 22:36 GMT (#77)
    (Utilizador Info) http://chbm.net/
    Claramente precisas de ir ler um livrinho sobre compiladores.


    Re:Então o problema é meu...? (Pontos:2)
    por PRE em 06-04-04 13:40 GMT (#22)
    (Utilizador Info) http://psantos.net
    Eu experimentei com o último FireFox e também não consegui usar a parte Java, mas nem me preocupei com isso, usei o formulário HTML.
    _____________________
    Pedro Santos :: psantos.net :: blog
    Re:Então o problema é meu...? (Pontos:2)
    por joaorf em 08-04-04 14:04 GMT (#80)
    (Utilizador Info)
    Mais um que desiste rápido... E depois queixam-se dos "joe users" e dos "mouse engineers"...
    A minha experiência (Pontos:2)
    por jadrian em 06-04-04 13:28 GMT (#18)
    (Utilizador Info)
    Saquei o programa para preencher o Modelo 3 Offline, versão Linux. Após efectuar o update à JRE funcionou tudo bem, preenchi simulei. Só que não consegui entregar!

    Nos modos de entrega tinha duas opções disponíveis:
    "Entregar declarações utilizando sistemas com software compatível"
    "Entregar declarações utilizando sistemas com software menos recente"

    A primeira não dava nada, experimentei com Mozilla 1.6, Firefox 0.8 e Konqueror 3.1.5. A segunda (em html) funcionava mas não tinha nenhuma opção para importar a declaração criada com o programa. Tive que preencher tudo de novo, online, e entregar sem simular pois essa opção também não existia.

    Agora reparo que já está disponível uma terceira opção!!
    "Entregar declarações previamente gravadas e validadas"

    Raios! :-/
    Re:A minha experiência (Pontos:2)
    por joaorf em 06-04-04 14:12 GMT (#24)
    (Utilizador Info)
    Não percebi bem o teu caso. Preencheste e simulaste usando a aplicação Java a correr independentemente, ou como applet?

    Eu preenchi o IRS usando Mozilla 1.6 + Sun Java 1.4.2-b28, a correr a aplicação como applet, e não tive problemas.

    Re:A minha experiência (Pontos:2)
    por jadrian em 06-04-04 14:48 GMT (#27)
    (Utilizador Info)
    Utilizei a aplicação JAVA para preenchimento offline do modelo 3. Depois não percebi como era suposto entregar o documento resultante... Nem sei bem o que queres dizer com isso de correr a aplicação como applet? É alguma coisa que está no site? Talvez aquela primeira opção na secção de entrega do modelo 3 que indiquei no meu post? Se é isso, aqui não deu nada (Blackdown JRE).
    Re:A minha experiência (Pontos:2)
    por joaorf em 06-04-04 14:49 GMT (#29)
    (Utilizador Info)
    Vamos por partes. Sabes o que é um applet Java?
    Re:A minha experiência (Pontos:2)
    por jadrian em 06-04-04 16:02 GMT (#34)
    (Utilizador Info)
    Yeap. Desculpa tinha lido mal.
    Utilizei a aplicação Java para preenchimento do modelo 3 offline. Testei tanto a versão para linux como a "genérica" (.jar). Funcionou bem, produzi um ficheiro com os meus dados, não consegui descobrir como havia de submeter os dados preenchidos.
    No programa não havia qualquer opção, na página da DGCI, secção de entrega do modelo 3, havia duas sub-secções. Uma com uma applet Java que não consegui correr, e outra em HTML. Na versão HTML não havia opção para importar os dados produzidos com a aplicação Java portanto tive de preencher tudo de novo, e submeter sem simular pois essa opção não existia.
    Voltei ao site hoje, e já está presente uma 3a opção para importar os dados produzidos pela aplicação Java.
    Re:A minha experiência (Pontos:2)
    por joaorf em 06-04-04 18:36 GMT (#41)
    (Utilizador Info)
    O botão de submissão dos dados está fora do applet, no canto superior direito.
    Re:A minha experiência (Pontos:1)
    por edsonmedina em 06-04-04 18:49 GMT (#48)
    (Utilizador Info)
    Eu preenchi o IRS usando Mozilla 1.6 + Sun Java 1.4.2-b28, a correr a aplicação como applet, e não tive problemas.

    Podes sempre olhar para a source da VM e tentar perceber o problema... pera... não podes, pois não?

    Então podes olhar para os logs/output e debuggar... ou não?


    Re:A minha experiência (Pontos:2)
    por CrLf em 06-04-04 21:59 GMT (#59)
    (Utilizador Info) http://crodrigues.webhop.net
    Podes sempre olhar para a source da VM e tentar perceber o problema... pera... não podes, pois não?

    Bzzzt! Podes.

    -- Carlos Rodrigues
    Re:A minha experiência (Pontos:1)
    por edsonmedina em 06-04-04 22:27 GMT (#62)
    (Utilizador Info)
    Podes sempre olhar para a source da VM e tentar perceber o problema... pera... não podes, pois não?

    Bzzzt! Podes.

    Epa, com essa é que me lixaste. Podes mesmo ver o source da VM da sun e corrigir um bug que encontres?


    sinceramente (Pontos:3, Engraçado)
    por ruben dig em 06-04-04 14:11 GMT (#23)
    (Utilizador Info) http://www.floppy.com.pt
    voces são todos uns tolos !
    a esforçarem-se para pagar IRS ...
    se ainda fosse para pedir subsidios :)
    eu nao pago irs porque o lynx não funciona bem com o site ... será que cola ?
    Re:sinceramente (Pontos:2)
    por Branc0 em 06-04-04 22:36 GMT (#63)
    (Utilizador Info) http://www.syners.org
    Para quem trabalha por conta de outrém, normalmente preenche-se o IRS para receber dinheiro. Para pagar vem todos os meses descontado no vencimento.

    Já estava na hora de começares a contribuir para a economia :P


    "Se vi mais além do que outro, é porque estava nos ombros de gigantes."
    Sir Isaac Newton

    Re:sinceramente (Pontos:2)
    por DomusOnline em 07-04-04 11:10 GMT (#71)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    E não se esqueçam de pôr lá a identificação de uma instituição de solidariedade social (ou religiosa) para receber os 0.5% do que pagámos.

    Mesmo com defeitos sempre deverá ser mais bem empregue que nos bolsos de algum corrupto.

    Cumprimentos.
    Nem por isso... (Pontos:2)
    por spyder em 06-04-04 14:24 GMT (#26)
    (Utilizador Info)

    ...e para correr offline só no sistema operativo dominante.

    Nope. Este ano preenchi, simulei, e submeti num FC1. Comecei o processo com um Firebird e acabei com um Firefox, ja agora :-D. A aplicacao em Java disponibilizada por eles funciona impecavelmente em Linux, pelo menos com a JVM que tenho instalada nesta maquina (J2RE 1.4.2).
    Re:Nem por isso... (Pontos:2)
    por Esqueleto em 06-04-04 16:48 GMT (#35)
    (Utilizador Info) http://www.tusofona.com
    Infelizmente não consegui tal coisa ... cada vez que clicava numa qualquer caixa de texto.. nada fazia.. não conseguia escrever nada.
    Nem na versão java nem na versão HTML.

    Deve ser fantasmas que tinha em casa... :)
    Re:Nem por isso... (Pontos:2)
    por DomusOnline em 07-04-04 11:20 GMT (#72)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    Que diabo... então não tiveste o mesmo problema que eu (nem consegui chegar ao Java por causa de um erro de JavaScript).

    Relatei acima num post meu. Ou é má configuração minha ou é algo com o Mozilla... de facto não testei com outros...

    Cumprimentos.
    Atenção (Pontos:2)
    por joaorf em 06-04-04 14:48 GMT (#28)
    (Utilizador Info)
    Aproveito para chamar à atenção dos mais incautos que devem criar um link simbólico para o plugin Java compilado com a mesma versão do GCC que o Mozilla que estão a usar. As últimas versões do JRE da Sun trazem três variantes do plugin:
    • ns4 - para Netscape 4 e Opera.
    • ns610 - para Netscape 6.1+ (ou equivalente Mozilla) compilado com gcc 2.9
    • ns610-gcc32 - para Netscape 6.1+ (ou equivalente Mozilla) compilado com gcc 3.2
    O Mozilla 1.4 ou mais recentes, e o Firefox, vêm compilados com gcc 3.x. Instruções mais detalhadas aqui.
    Re:Atenção (Pontos:2)
    por DomusOnline em 06-04-04 15:07 GMT (#30)
    (Utilizador Info) http://bandalarga.domus.online.pt/
    Hmmmm.... eu tenho o 1.3... Lembro-me dessa questão e ia jurar que o plugin antigo funcionava... BINGO... não estou na máquina neste momento. Mas a 1ª vez que fui ao site tinha o 1.4.0 e o site mandou-me ir buscar o 1.4.2 (presumivelmente a applet funcionou). A partir da instalação deste começou com o erro de JS. Deve ter sido isso. Lembro-me de ter escolhido explicitamente o da versão 3.2 do GCC pois é a que tenho. Mas provavelmente meti o Mozilla por RPM (não me lembro) e portanto será ainda compilado com o 2.9.

    Deve ser isso. De qualquer forma muito obrigado pelo lembrete. Agora está a fazer sentido. Mais tarde verifico.

    Cumprimentos.
    Re:Atenção (Pontos:1)
    por henrique em 06-04-04 20:27 GMT (#54)
    (Utilizador Info)
    E acrescento que os JRE para Linux podem ser importados daqui. Há lá versões para AMD64, Sparc, Arm...
    Mas.. podes entregar sem ser com uma applet.. (Pontos:1)
    por foo em 06-04-04 20:28 GMT (#55)
    (Utilizador Info)
    eu até fiquei impressionado com os tipos este ano, têm lá uma aplicação em java muito boa por acaso.. até tem instalador para windows, solaris, linux, macosx e outros sistemas unix. acham que é assim tão mau? eu com o macosx e o safari entreguei sem problemas nenhuns.

    menu do lado esquerdo -> downloads -> IRS

    um mimo :) os tipos do opensoft estão de parabéns

    Re: Pois, pois ... (Pontos:2)
    por gass em 07-04-04 18:36 GMT (#74)
    (Utilizador Info) http://otiliamatos.ath.cx
    estou neste momento em espera, para tentar fazer uma reclamaço... tenho, aki no escritorio 10 pc's em rede e tenho vindo a utilizar ker o samba ker o apache para as applets java. O que nao tava a espera e que mudassem essa mesma aplicaçao.... e certo quie esta melhor, mais bonita e tal ... mas em windows xp, fornecida por samba, funciona maravilhosamente com o java da sun, e em windows 98 nops, com o mesmo java ... no entanto pelo site, funciona as mil maravilhas. Nao, nao posso usar o do site, pois apenas 2 pcs tem acesso a net. os restantes sao preenchidos offline. Mas como raio uso akilo? e que vem compilado, desta vez nada de html .... alguem tem problema similar?
    Cumps-
    Gass
    Re: Pois, pois ... (Pontos:2)
    por joaorf em 08-04-04 13:53 GMT (#78)
    (Utilizador Info)
    Alguém sabe dizer-me em que língua foi escrito o comentário anterior?

     

     

    [ Topo | Sugerir artigo | Artigos anteriores | Sondagens passadas | FAQ | Editores | Preferências | Contacto ]