gildot

Topo
Sobre
FAQ
Tópicos
Autores
Preferências
Artigos
Sondagens
Propor artigo


8/3
gildicas
9/30
jobs
10/9
perguntas
10/25
press

 
Telepac hijacking...
Contribuído por ajc em 28-10-03 17:13
do departamento huh?
And now for... :-) acdm escreve "Boas pessoal, Há tempos quando se deu a cena dos wildcards na Verisign le aqui com grande atenção e interesse o desenvolvimento e resolução. Entretanto notei (tal como pessoal aqui) o que estava a acontecer com clientes da Telepac a ir parar ao SAPO por quando o domínio não existe. Acabei por enviar na semana passada uns tantos emails a entidades responsaveis por COM. NET e ORG relatando situação e procurando se teriam conhecimento do mesmo e comentários. Expliquei também de forma resumida a posição dominante do grupo PT e um toque a presença no NASDAQ (nice oportunity for lawsuit) "

Hoje recebi uma reacção mas estou perdido quanto à resposta e queria contar com o vosso expertise para dar uma resposta com cabeça tronco e membros a ver se assim dá para forçar a Telepac a mudar a atitude ganhando assim 5 min de respeito e admiração da "geekalhada" aqui do Gil e por consequência ter Portugal a meus pés.. *cof* *cof* ahh pois e conseguir algo que a ANACOM ou defunto ICP nunca conseguiram.

Então é assim eu no email original posso ter induzido os receptores em erro porque aleguei que existiam wildcards na DNS agora olhando para a situação parece-me mais uma situaão de a Telepac nos estar a Hijack'ar o browser através da proxy transparente seja como for perguntam-me específicamente:

-"What domain name is this Telepac company responsible for? And what record have they added?" (não me parece ser relavante)
-"Or do you say they have changed their full-service-resolvers so people using their resolver will always get a match regardless of whether thereis a record in DNS or not" (nã sê, nã vej-boi-diss)

Muchas gracias.

PLC em Espanha, Portugal espera pela EDP | Manual do Nmap  >

 

gildot Login
Login:

Password:

Referências
  • Mais acerca And now for... :-)
  • Também por ajc
  • Esta discussão foi arquivada. Não se pode acrescentar nenhum comentário.
    Quem nao sabe nao ve... (Pontos:2, Esclarecedor)
    por leitao em 28-10-03 17:27 GMT (#1)
    (Utilizador Info) http://scaletrix.com/nuno/blog/
    -"Or do you say they have changed their full-service-resolvers so people using their resolver will always get a match regardless of whether thereis a record in DNS or not" (nã sê, nã vej-boi-diss)

    Se "na se", "na vej-boi-diss" para que e' que perguntaste ?

    Alguma investigacao preliminar tinha fortalecido o teu argumento acho eu.


    "I triple guarantee you, there are no American soldiers in Baghdad.", Mohammed Saeed al-Sahaf, Iraqi Minister of Information

    Re:Quem nao sabe nao ve... (Pontos:1)
    por liberdade em 28-10-03 18:22 GMT (#3)
    (Utilizador Info)
    +1
    Re:Quem nao sabe nao ve... (Pontos:1)
    por acdm em 28-10-03 18:53 GMT (#6)
    (Utilizador Info)
    Caro Leitão,

    Não está implicito o quê e porquê?

    Oink!
    Afinal, qual é o problema ? (Pontos:1)
    por moonrider em 28-10-03 18:07 GMT (#2)
    (Utilizador Info) http://127.0.0.1
    Eu estou neste momento ligado na rede da Telepac, e não estou a ver nada de anormal...

    > isto-nao-resolve.com
    Server: ns.telepac.pt Address: 194.65.3.20

    *** ns.telepac.pt can't find isto-nao-resolve.com:
    Non-existent host/domain

    No proxy também não existe nada de anormal, quando escolho um domínio não existente, devolve-me o erro do próprio do browser...

    Devias ter colocado essa questão ANTES de enviar o email ( já agora, quem são as "entidades responsáveis" para onde enviaste o email ? ) ?
    Re:Afinal, qual é o problema ? (Pontos:1)
    por liberdade em 28-10-03 18:23 GMT (#4)
    (Utilizador Info)
    estarão os editores a gozar com o rapaz ao categorizar este item nas "piadas"?? Acho que mais valia rejeitar...
    Re:Afinal, qual é o problema ? (Pontos:2, Informativo)
    por foo em 28-10-03 19:02 GMT (#7)
    (Utilizador Info)
    já agora, eu tenho adsl.pt e não tenho redirecionamento algum quando uso um endereço .com inexistente.
    Não batam mais... (Pontos:2, Informativo)
    por acdm em 28-10-03 18:51 GMT (#5)
    (Utilizador Info)
    Bem sei que em Tugal quem protesta não é bem visto mas seja como for insisto já q continuo a achar que o que eles fazem é abusivo...

    Explicando: Através do SAPO.ADSL (casa) e do ADSL.PT (emprego) metendo um domínio que não existe vou (vamos porque na mailing list ADSL utilizadores no yahoo há mais quem se queixe) parar a uma pesquisa ao SAPO (URL abaixo).

    Se uso um proxy (neste caso alemão) dá-me a mensagem de erro normal no browser could not resolve bla bla.

    http://pesquisa.sapo.pt/?q=istonaobule&host=www.istonaobule.com&ptr=m
    Re:Não batam mais... (Pontos:2)
    por nmarques em 28-10-03 19:28 GMT (#9)
    (Utilizador Info) http://morgul.xpto.org
    Homens de barba rija abrem o jogo. Pessoalmente considero que a tua noticia nao tem credibilidade nenhuma, ou abres o jogo, ou calas-te e segues a tua guerra santa com a Telepac. Pessoalmente de varias maquinas ligadas a' Telepac, tal nao me acontece... logo, eu diria, isso e' problema teu, normalmente e' do tipo de problemas localizado entre a cadeira e o teclado. Eu posso a qualquer momento provar que a Telepac nao e' responsavel, porque eu como cliente Telepac nao sofro nem sofri desse efeito.

    Nelson Marques
    -------------------------------------------------------
    Seja sangue e suor o caminho para a vitoria,
    lutaremos lado a lado pela pátri
    Re:Não batam mais... (Pontos:1)
    por jamaica em 28-10-03 21:24 GMT (#13)
    (Utilizador Info) http://latencias.pt.vu
    Pessoalmente de varias maquinas ligadas a' Telepac, tal nao me acontece... logo, eu diria, isso e' problema teu, normalmente e' do tipo de problemas localizado entre a cadeira e o teclado. Eu posso a qualquer momento provar que a Telepac nao e' responsavel, porque eu como cliente Telepac nao sofro nem sofri desse efeito

    E' obvio que nao sofres.. se leres bem esta situacao so' afecta clientes Sapo ADSL :)
    ---------------------
    The worst moment for the atheist is when he is really thankful and has nobody to thank. Dante Rossetti

    Re:Não batam mais... (Pontos:1)
    por acdm em 28-10-03 22:46 GMT (#15)
    (Utilizador Info)
    Não tenho jogo a esconder nem luto contra moinhos...

    Acho que a coisa está bem explícita não se trata de um "default search" ao nivel do browser (alias tanto acontece com IE como com opera) e se vires o resultado no URL abaixo verificar a "mensagem de erro" isto é a proxy transparente da telepac não encontrou o domínio e como tal fez uma pesquisa.
    Re:Não batam mais... (Pontos:2)
    por racme em 28-10-03 21:00 GMT (#11)
    (Utilizador Info) vendetta.guildsoftware.com

    Explicando: Através do SAPO.ADSL (casa) e do ADSL.PT (emprego) metendo um domínio que não existe vou (vamos porque na mailing list ADSL utilizadores no yahoo há mais quem se queixe) parar a uma pesquisa ao SAPO (URL abaixo).


    pensava eu que essa historia ja tinha ficado resolvida, a' muito!?


    Contribuído por BladeRunner em 06-10-03 14:44
    do departamento marcha-à-ré
      [BladeRunner]: Salvo erro ou omissão da minha parte, o SAPO já tinha mandado os wildcards abaixo há vários dias.




    Those who do not understand Unix are condemned to reinvent it, poorly.
    -- Henry Spencer
    Re:Não batam mais... (Pontos:1)
    por liberdade em 28-10-03 21:17 GMT (#12)
    (Utilizador Info)

    Mas se tu nem sabes o que é que eles tão a fazer, ou se são eles, nem tão pouco explicar a situação...
    Acho que podiamos ficar por aqui...


    Re:Não batam mais... (Pontos:1)
    por acdm em 28-10-03 22:50 GMT (#16)
    (Utilizador Info)
    De que são eles (telepac) não tenho eu qq dúvida.
    Re:Não batam mais... (Pontos:2)
    por CrLf em 28-10-03 23:16 GMT (#20)
    (Utilizador Info) http://crodrigues.webhop.net
    e do ADSL.PT (emprego) metendo um domínio que não existe vou (vamos porque na mailing list ADSL utilizadores no yahoo há mais quem se queixe) parar a uma pesquisa ao SAPO (URL abaixo).

    Sou utilizador adsl.pt e a mim isto não acontece, PBCAK talvez?

    -- Carlos Rodrigues
    Re:Não batam mais... (Pontos:2)
    por André Simões em 29-10-03 1:05 GMT (#23)
    (Utilizador Info) http://andre.catus.net
    Pois a mim, com sapo.adsl não acontece nada disso. O mozilla simplesmente diz que não encontra o endereço. A mesma coisa com o Konqueror. Experimentaste isso com quê? Internet Exploder?

    ---
    Omnia aliena sunt: tempus tantum nostrum est. (Séneca)
    "Tudo nos é alheio: apenas o Tempo é nosso."

    Re:Não batam mais... (Pontos:2)
    por jpgm em 29-10-03 12:02 GMT (#30)
    (Utilizador Info)
    Bem sei que em Tugal quem protesta não é bem visto mas seja como for insisto já q continuo a achar que o que eles fazem é abusivo...
    Meu amigo, esse género de argumentação só vem tirar força ao teu caso....
    Em Portugal (Tugal não sei onde é), ou noutro sitio qualquer, é sempre válido protestar contra o que está mal... Agora, é necessário fundamentar esse protesto, se não consegues, ou não sabes, fundamentar a tua queixa, não te desculpes no facto de "quem protesta não é bem visto", porque para mim, não é bem visto quem anda a "arrotar postas de pescada"...
    Não quero com isto dizer que o que a telepac, ou sapo, ou pt fazem é certo ou errado, devias saber o que dizer antes de o dizer às "entidades competentes", de modo a evitar os, sempre desagradáveis, "nã sê, nã vej-boi-diss"
    Por último, e referente à queixa sobre o tal Tugal, caro amigo, a porta (fronteira) está aberta à vários anos, oportunidades não faltam, faz-te à vida...
    Cumprimentos! zp
    Será algo do browser? (Pontos:1)
    por foo em 28-10-03 19:04 GMT (#8)
    (Utilizador Info)
    Que browser usas?... é que é possível, pelo menos no IE, tê-lo configurado de forma a ir parar a algum site quando colocas um endereço que não exista..

    eu tenho esse problema no trabalho, algo que uma vez se instalou automaticamente no IE e que agora não sei tirar :) sempre que coloco um endereço que ele não resolve vai parar a um site qualquer que agora não me lembro.
    Ainda bem que normalmente uso o Mozilla :)

    Re:Será algo do browser? (Pontos:2)
    por ruben dig em 28-10-03 20:07 GMT (#10)
    (Utilizador Info) http://www.floppy.com.pt
    isso é porque os sites de serials e afins instalam trojans se as definicoes do IE estiverem em medio-baixo na seguranca de sites de Internet, existem programas anti-adware que identificam isso e removem automaticamente
    Re:Será algo do browser? (Pontos:1)
    por acdm em 28-10-03 22:43 GMT (#14)
    (Utilizador Info)
    Tal como já expliquei o que acontece não se limita a uma questão do browser mas sim à Telepac senão como se explica que xpto123.com leva a pesquisa no sapo e se forço uma proxy chamemos-lhe yaddayadda.de o browser gera a mensagem de erro sem resultar na tal pesquisa no sapo é obviamente algo implementado na Telepac.
    Re:Será algo do browser? (Pontos:1)
    por acdm em 28-10-03 22:58 GMT (#17)
    (Utilizador Info)
    A página www.istonaobule.com não se encontra disponível, como tal efectuámos uma pesquisa por istonaobule.
    Re:Será algo do browser? (Pontos:2)
    por André Simões em 29-10-03 1:08 GMT (#24)
    (Utilizador Info) http://andre.catus.net
    Mas já experimentaste com outro? É que eu tenho sapo.adsl e não me acontece nada disso com o Mozilla nem com o Konqueror, que se limitam a dar normais mensagens de erro. Que browser usaste? Internet Exploder? Se sim, aconselho-te a sacares a o Mozilla e experimentar. É que a mim, repito, cliente sapo.adsl, não acontece nada disso.

    ---
    Omnia aliena sunt: tempus tantum nostrum est. (Séneca)
    "Tudo nos é alheio: apenas o Tempo é nosso."

    Re:Será algo do browser? (Pontos:2)
    por higuita em 29-10-03 7:01 GMT (#27)
    (Utilizador Info)
    a resolucao e' simples... nunca uses o IE e vais ver que o "auto-instalador" do IE nunca mais te volta a chatear...

    se queres mesmo remover essa coisa do IE, comeca por desligar o suporte para extensoes de terceiros do IE, o install on demand e o "enable syncronization"
    depois corres o msconfig (ou o regedit+explorer no start menu para emular a falta deste) e remover do arranque o lixo que o IE instala
    talvez antes deste passo devas matar todos os processos relacionados com o que vais remover, pois alguns voltam a instalar-se sempre de novo no shutdown se ainda estiverem a correr

    resumindo, alem de o mozilla ser bastante melhor que o IE, so' um doido ou quem nao sabe e' que se arrisca a usar o IE na net hoje em dia, considerando a quantidade e a qualidade de tralha que o IE instala...

    Higuita
    De quem é a culpa??? (Pontos:2, Interessante)
    por theone em 28-10-03 23:11 GMT (#19)
    (Utilizador Info)
    Vamos lá esclarecer esta questão de uma vez por todas.

    Este caso nao tem nada a haver com o exemplo da Verisign, que andou por aí a brincar com os domínios. Aqui, a culpa é, claro, da Microsoft. Agora, é o famoso Autosearch do Internet Explorer. Podem desactiva-lo em Tools|Internet Options|Advanced|When Searching e escolham "Do no search from the address bar" (IE6.0)

    Esta coisa o que faz, é direccionar o utilizador para a pagina auto.search.msn.com sempre que é introduzido uma página que nao existe. O giro aqui é que a pagina está a fazer o forward para http://pesquisa.sapo.pt/?q=...

    Engraçado, não? Parece que a Microsoft anda a vender o seu serviço a quem pagar mais :)

    Aqui fica um sniff porreiro:

    GET /response.asp?MT=www.lkjlkjerwer.com&srch=5&prov=&utf8 HTTP/1.1
    Accept: image/gif, */*
    Accept-Language: pt
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
    Host: auto.search.msn.com
    Connection: Keep-Alive
    Cookie: SITESERVER=ID=UID=...; pgmarketnoexp=en-us; mh=MSFT; smc_g=v=1&pvs=classic&ssp=1&df=1; smc_classic=df=1&af=0&rc=15&nw=0&sc=1&rs=1; smc_cid=id=...

    HTTP/1.1 302 Found
    Date: Tue, 28 Oct 2003 21:48:46 GMT
    Server: Apache/1.3.26 (Unix) mod_perl/1.26
    Location: http://pesquisa.sapo.pt/?q=lkjlkjerwer&host=www.lkjlkjerwer.com&ptr=m
    Connection: close
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=iso-8859-1

    O primeiro forward, para o auto.search.msn.com é o browser que o faz, e o segundo, é o server da microsoft.

    Por vias das dúvidas, eu punha uma regra'zita na firewall :)))
    Re:De quem é a culpa??? (Pontos:2)
    por 4Gr em 28-10-03 23:32 GMT (#21)
    (Utilizador Info)
    Uma vez mais, Microsoft em prática do seu abuso de poder dominante :-)

    Fico feliz de cada vez que ouço algo do género e sei que nas minhas máquinas software da Microsoft não para! E fico triste de saber que ainda há quem se deixe abusar...


    Dominus vobiscum
    Re:De quem é a culpa??? (Pontos:1)
    por Devil_PT em 28-10-03 23:39 GMT (#22)
    (Utilizador Info)
    Baboseiras. Já ouviste de proxies transparentes, por acaso?
    Re:De quem é a culpa??? (Pontos:1)
    por RedBot em 29-10-03 2:44 GMT (#25)
    (Utilizador Info) http://www.ebserver.org
    Se e' o autosearch do IE, entao pq e' que ainda ontem com phoenix[firebird] (sim em windows...sera a culpa do windows e nao da telepac ?) fui ter a uma dessas procuras automagicas do sapo? (adsl sapo)

    http://www.ebserver.org
    Há 10 tipos de pessoas no mundo, as que entendem binário, e as que nao entendem. [stolen
    Re:De quem é a culpa??? (Pontos:1)
    por Ancestor em 29-10-03 3:51 GMT (#26)
    (Utilizador Info)
    Curioso que acabei de experimentar no IE 6 e realmente direcciona para o sapo, mas com o Mozilla 1.5 isso não acontece, como seria de esperar.
    Re:De quem é a culpa??? (Pontos:1)
    por theone em 29-10-03 7:39 GMT (#28)
    (Utilizador Info)
    Eu já...

    E tu, pelos vistos, também. Mas arrisco dizer que só ouviste falar mesmo ao de leve.

    Não percebo... as pessoas em vez de investigaram como eu fiz, poe-se a mandar bitaites sem pés nem cabeça. Só para lançar confusão. Lamentável...

     

     

    [ Topo | Sugerir artigo | Artigos anteriores | Sondagens passadas | FAQ | Editores | Preferências | Contacto ]