gildot

Topo
Sobre
FAQ
Tópicos
Autores
Preferências
Artigos
Sondagens
Propor artigo


8/3
gildicas
9/30
jobs
10/9
perguntas
10/25
press

 
KDE e o copy/paste mortifero
Contribuído por BladeRunner em 29-09-01 15:14
do departamento manda-pró-dpto-de-bugs-do-kde
KDE Lowgitek escreve "Descobri infelizmente o quão fraco é o meu KDE :(
E antes que começem para aí a dizer que descobri a pólvora, o que se passa é o seguinte: observei que ao colar uma string consecutivamente no KDE, tenha ela o tamanho que tiver, em pouco tempo (mesmo muito pouco tempo) o meu KDE crasha. Seja isso em que lado for vejam se conseguem assassinar por um bocadinho aí o aparelhómetro em casa tb com um simples copy & paste.
A aventura é conseguida praí no 8º ou 10º copy & paste :("
Esta situação é demasiado incómoda de se suportar, principalmente quando se querem fazer tarefas repetidas.
Gostaria de um feedback para saber se isso é um problema aqui local ou se a coisa está mesmo assim feita (mau por sinal ;) )
A situação ocorreu com um ps2/ms internet KDE 2.2.1 xfree 4.1.1
Até tenho medo de usar o rato ehehe ;)

caixa magica v1.0beta já está disponivel | Livro de reclamações  >

 

gildot Login
Login:

Password:

Referências
  • Mais acerca KDE
  • Também por BladeRunner
  • Esta discussão foi arquivada. Não se pode acrescentar nenhum comentário.
    KDE == Windoze (Pontos:1)
    por jamaica em 29-09-01 15:47 GMT (#1)
    (Utilizador Info) http://ainda.nao.tenho
    Realmente quando andava a experimentar o KDE acorriam-me erros deste e doutro tipo, por vezes ao simples facto de arrastar um ícone todo o KDE estoirava, levando o X atrás..

    o AfterStep rula e não há discussão possivel :)
    ---------------------
    do rio que tudo arrasta diz-se que é violento,
    mas ninguem diz violentas as margens que o oprimem.
    Berthold Brecht

    Não confirmo!! (Pontos:1)
    por flipoide em 29-09-01 16:38 GMT (#2)
    (Utilizador Info)
    Já fiz copy & paste (com o rato) N vezes e não me aconteceu nada! Uso o kde 2.2.1 (suse 7.0) e o xfree 3.3.6.

    Flip
    Re:Não confirmo!! (Pontos:1)
    por Lowgitek em 30-09-01 15:11 GMT (#19)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    o x que tou a usar é bastante diferente desse que tas a usar mas acho como alguem aqui tb ja disse que o problema esta no QT
    A unica coisa que tu descobriste foi que.... (Pontos:2, Esclarecedor)
    por Castanheiro em 29-09-01 17:03 GMT (#3)
    (Utilizador Info) http://students.fct.unl.pt/users/fdc10056
    ... tens uma instalação do kde mal feita ou corrumpida, e quem diz kde pode dizer X. Tou farto de fazer copy/paste e nunca o kde me crashou, ao ler o artigo até fui experimentar fazer copy paste intensivamente da mesma string e nada.....solid as a rock! Não fossem os drivers da nvidia (que até estão melhores nestas últimas versões) e podia dizer que o X não me crashava há (muitos) meses.

    Enfim, um artigo completamente desnecessário. Mesmo que por uma muitoooo remota possibilidade esse bug existir mesmo e ser da responsabilidade do kde não seria mais sensato verificar junto dos autores primeiro se é mesmo um bug ou não antes de vir para a praça pública apontar o dedo?
    Re:A unica coisa que tu descobriste foi que.... (Pontos:1)
    por Lowgitek em 30-09-01 15:05 GMT (#16)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Postei a coisa simplesmente porque em todas as maquinas que experimentei e foram 4 o resultado foi sempre o mesmo. Nunca disse que problema não poderia ser uma instalação quiça mau feita mas confie na intalaçao feita pela minha distribuição.


    Re:A unica coisa que tu descobriste foi que.... (Pontos:1)
    por Castanheiro em 30-09-01 16:38 GMT (#23)
    (Utilizador Info) http://students.fct.unl.pt/users/fdc10056
    Isso é deveras esquesito, que versão do QT e que distribuição é que usas? Tens alguma coisa compilada à mão ou tens tudo em rpm's/deb/whatever?

    É que eu já tive n combinações de qt+xfree+kde+rato e nunca tinha visto/ouvido falar em tal coisa.
    Esquece.. (Pontos:1)
    por Castanheiro em 30-09-01 16:44 GMT (#24)
    (Utilizador Info) http://students.fct.unl.pt/users/fdc10056
    ... vi num outro post teu que estás a utilizar o qt3, esse nunca experimentei, e acho que acabaste de encontrar um grande candidato a responsável pelos crashes.
    Re:A unica coisa que tu descobriste foi que.... (Pontos:2)
    por CrLf em 30-09-01 22:31 GMT (#26)
    (Utilizador Info) http://students.fct.unl.pt/~cer09566
    Tenta fazer um paste de uma string maior do que 5.5Kb num QLineEdit em qualquer programa QT... crash!

    -- Carlos Rodrigues

    - "I think we can handle one little penguin!"
    - "No, Mr. Gates, your men are already dead!"
    Nopes... (Pontos:2)
    por [WaR] em 29-09-01 17:11 GMT (#4)
    (Utilizador Info)
    O bug é teu.

    -- [WaR]
    "making rumours true since 1994"
    mais um... (Pontos:3, Interessante)
    por RaTao em 29-09-01 17:52 GMT (#5)
    (Utilizador Info)
    troll!

    *EXACTAMENTE* (note-se o bold e as maiúsculas) o mesmo tipo do recentemente posted aqui no gil sobre "linux: instabilidade?".

    http://www.gildot.org/article.pl?sid=01/09/27/1348228&mode=nested

    o último ainda levou uma analogia. este nem isso merece.

    para (não) variar temos a generalização (kde é mau como as cobras), não temos comparações com outros copy+paste, não temos logs do X ou do sistema, não sabemos se o gpm está a correr, etc.

    pior, frases destas não ajudam:
    "Descobri infelizmente o quão fraco é o meu KDE :("

    "...descobri a pólvora..."

    agora faltam os comentários preciosos do C... e do N...... a dizer "eu bem te disse". ehehehhe can't wait!

    bladerunner... tu usas kde, não usas? já te encravou a fazer um copy+paste?
    olha... eu acabei de fazer uma data de copy+paste e não encravou -- deve ser sorte!!!!

    por fim, tenho que admitir que também estou a errar ao alimentar os bichinhos.


    Regards,
    Nuno Silva aka RaTao
    Re:mais um... (Pontos:2)
    por Gamito em 29-09-01 19:43 GMT (#6)
    (Utilizador Info)
    bladerunner... tu usas kde, não usas? já te encravou a fazer um copy+paste?

    Sim!
    Tenho SuSE 7.0 com o X 4.1.0 (rpms da SuSE) e com a Qt 2.3.1 e o KDE 2.2.0 compilados à pata.
    Não tenho esse problema.

    Penso contudo que o autor do artigo também usa e gosta do KDE e estava apenas a ser irónico.

    Ou então sou eu que já não estou a perceber patavina disto :-)

    Mário Gamito
    educação, ensino
    Re:mais um... (Pontos:1)
    por RaTao em 30-09-01 5:10 GMT (#14)
    (Utilizador Info)
    o autor do artigo gosta de kde? pelo tipo de frases usadas não me está a parecer... mas eu não sou um "profiler", por isso nem vou julgar essa frase.

    o que me está a parecer é que vai ser exactamente como no outro artigo que mencionei acima: "linux: instabilidade?", i.e.:

    montes de gente a tentar ajudar a fazer perguntas sobre o ambiente/caso especifico do (l)user e ele nem responde...
    se estes dois artigos não são troll's enganaram-me muito bem,
    parabens!


    Regards,
    Nuno Silva aka RaTao
    Re:mais um... (Pontos:3, Interessante)
    por Strange em 29-09-01 19:49 GMT (#7)
    (Utilizador Info) http://strange.nsk.yi.org/

    Eu não uso o KDE, e para ser franco também não gosto muito.

    Mas também não vejo razão para artigos (não o teu comentário) como este, em que acontece algo incomum a um tipo no uso normal de um SO, que pode ser bug ou não, mas essa pessoa em vez de ir aos canais apropriados (news, mailing lists de linux e kde, etc) a dizer o que lhe acontece e dar informações adicionais e perguntar o que se pode fazer para resolver a situação, vem para um fórum público a dizer, neste caso, que o KDE é fraco...

    E ainda tem a ousadia de dizer que tem o conhecimento de que não descobriu a pólvora. Engano-me ou assim dá a entender que toda a gente sabe quão fraco é (o meu) KDE?

    Viva o KDE! Viva o GNOME! E submentam bug reports quando for o caso e usem os canais apropriados. Não venham fazer queixinhas de algo que desconhecem para o Gildot....

    hugs
    Strange

    Re:mais um... (Pontos:2)
    por Gamito em 29-09-01 20:07 GMT (#8)
    (Utilizador Info)
    Mas também não vejo razão para artigos (...) como este

    Viva!

    Este tipo de artigos têm aparecido cada vez com maior frequência.
    Dois exemplos recentes são o dos faxes/modems e o da placa de vídeo.

    Há outros do género (e piores) em queue.

    Provavelmente é um reflexo do crescimento do Gildot e do apagamento do pt.comp.so.linux que era suposto ser o sítio mais lógico em .pt onde ir primeiro em busca de auxílio ou deste tipo de troca de ideias, como se queira.

    É evidente, que como mero utilizador/leitor do Gildot, e em minha opinião pessoal que não vincula o Gildot também concordo contigo que não é para este tipo de artigos que citei que este fórum serve.

    Contudo, como é fim-de-semana, é altura de relaxe e nem sempre é preciso levar tudo muito a sério, lá passou este pelas minhas mãos, como os os outros passaram na sua altura por outras...

    BTW... repara no departamento que coloquei no artigo.

    Mário Gamito
    educação, ensino
    Re:mais um... (Pontos:1)
    por Lowgitek em 30-09-01 15:24 GMT (#21)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Tens toda razão.

    Se o Mr. anterior tivesse feito um comentário como este era muito mais facil de se aceitar com paciencia clareza e educação.

    Infelizmente nem toda gente é assim. Em relação ainda a colocação ao artigo a culpa em parte é do proprio gildot que não informa convinientemente a natureza dos artigos em causa que devem ser propostos mais ainda a culpa final é sempre de quem aprova o artigo que ate vver deveria estar mais informado do que o mero utilizador.
    Re:mais um... (Pontos:1)
    por Lowgitek em 30-09-01 15:20 GMT (#20)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Err... eu puz a coisa na secção perguntas.....

    Esperava que alguem com mais experiencia do que eu pudesse me dar uma pista. Ja sabia que iam chover flames.

    as essa pessoa em vez de ir aos canais apropriados (news, mailing lists de linux e kde, etc) a dizer o que lhe acontece e dar informações adicionais e perguntar o que se pode fazer para resolver a situação, vem para um fórum público a dizer, neste caso, que o KDE é fraco..."

    Realmente partes do pressupostos que assim não o fiz ou então es mesmo casmurro e não conseguiste perceber a ironia da situação. Eu não estava a dizer que o kde não presta se assim fosse pensava em usar outra coisa mas antes pelo contrario o que eu queria dizer e que poderia estar a fazer algo que não fosse 100% correcto nem la perto e que ate podia ser resolver bem.
    Felizmente nao preciso da TUA AJUDA para fazer alguma coisa e sinceramente gajos como tu ajudam muito pouo porque reparar nos problemas dos outros é facil quando se trata a ajudar e dar uma informação util 0!

    Felizmente ainda há pessoas que não pensam como tu e realmente sabem o que é ajudar aqueles que ainda dão os seus passos iniciais.

    Em relação a informação ter sido posta aqui eu apenas propos o artigo com uma intenção única ser informado e se possivel ajudar quem possa estar a ter o mesmo problem é para issso que penso que tambem existe o gildot se não gostaste do comentário so tens uma coisa a fazer e não o leres. (PONTO)
    "


    Re:mais um... (Pontos:2)
    por Strange em 30-09-01 16:14 GMT (#22)
    (Utilizador Info) http://strange.nsk.yi.org/

    se não gostaste do comentário so tens uma coisa a fazer e não o leres. (PONTO)

    AH! E como posso eu saber se gosto ou não do comentário sem antes o ler?!? Não sou clarividente nem classifico os comentários apenas pelo assunto ou por quem o enviou...

      as essa pessoa em vez de ir aos canais apropriados (news, mailing lists de linux e kde, etc) a dizer o que lhe acontece e dar informações adicionais e perguntar o que se pode fazer para resolver a situação, vem para um fórum público a dizer, neste caso, que o KDE é fraco..."

      Realmente partes do pressupostos que assim não o fiz ou então es mesmo casmurro e não conseguiste perceber a ironia da situação

    Bem, não vi nenhuma mensagem nos canais que costumo prestar atenção, mas ligo a poucos. Mas duvido que tenhas tentado todos os canais possiveis (especialmente a mailing list do KDE) senão nunca teria sido necessário enviares esta mensagem para o Gildot...

    E de que ironia falas tu? Ironia: figura de estilo que veicula um significado contrário daquele que deriva da interpretação literal do enunciado; zombaria. Chegas aqui e dizes que o teu KDE é fraco. Que crasha por uns simples cut&paste... Agora tenho eu que adivinhar que é por falares mal do KDE que afinal o KDE é execelente e afinal não acontece o que dizes que acontece?! "Ironia da situação? A situação é que o teu KDE crasha por uns cut&pasts! Achas mal que tenha pensado que estavas a deitar abaixo o KDE, como outros também pensaram?

    Felizmente nao preciso da TUA AJUDA para fazer alguma coisa e sinceramente gajos como tu ajudam muito pouo porque reparar nos problemas dos outros é facil quando se trata a ajudar e dar uma informação util 0!

    E conseguiste ajuda preciosa nalgum outro comentário? Talvez apenas a confirmação de que também lhes acontece; ou que não lhes acontece; ou que o problema é do X; ou é do Qt....

    Felizmente ainda há pessoas que não pensam como tu e realmente sabem o que é ajudar aqueles que ainda dão os seus passos iniciais.

    Desculpa lá, mas quem me conhece e quem tem reparado nos meus posts no gildot sabe que gosto de ajudar. Mas como toda a gente a minha paciência tem limites e achei o teu artigo inapropriado e insultuoso.

    Não acharias mais útil um artigo a dizer o problema que tiveste e que tinha enviado email para várias listas (principalmente a da KDE) e que o problema estava em tal sítio e em tal versão e que para resolver bastaria fazer tal e tal?

    Desculpa-me lá, embora prefira gnome ainda tenho grande respeito pelos do KDE e duvido que não te soubessem responder à tua questão se tivesses enviado email para lá.

    Ah! Também acho piada a teres deitado culpas ao Gildot... Afinal, o título de Notícias sobre Linux... e não só está lá apenas para enfeitar...

    hugs
    Strange

    Re:mais um... (Pontos:1)
    por Lowgitek em 30-09-01 18:08 GMT (#25)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Não é para alimentar mas ....

    "Bem, não vi nenhuma mensagem nos canais que costumo prestar atenção, mas ligo a poucos. Mas duvido que tenhas tentado todos os canais possiveis (especialmente a mailing list do KDE) senão nunca teria sido necessário enviares esta mensagem para o Gildot..."

    Então andas a ver mau ... O post la esta e um deles foi a mailing list da suse.

    "E conseguiste ajuda preciosa nalgum outro comentário? Talvez apenas a confirmação de que também lhes acontece; ou que não lhes acontece; ou que o problema é do X; ou é do Qt.... "

    Consegui, se tivesses lido com olhos de ler expus mais que um problema. Um deles graças a um post fez me procurar informação especifica nomeadamente em relação ao problema da nvidia que me forçava fazer um reset a bruta agora vi que existem alternativas menos drasticas.

    "Mas como toda a gente a minha paciência tem limites e achei o teu artigo inapropriado e insultuoso."

    Realmente devo ter ofendido toda uma nação por dizer que o MEU KDE não esta a 100%.

    "Não acharias mais útil um artigo a dizer o problema que tiveste e que tinha enviado email para várias listas (principalmente a da KDE) e que o problema estava em tal sítio e em tal versão e que para resolver bastaria fazer tal e tal?"

    Para ti o problema então se resolveria com adição que ja tinha colocado o problema em varias listas pronto era menos insultuoso.

    Em relação a soluções ainda não achei solução definitiva para o problema nem vi ninguem que o tivesse feito, por enquanto aquilo que fiz foi desintalar tudo o que fosse relacionado com o QT e intalado de novo... o problema agora esta intermitente.

    "Ah! Também acho piada a teres deitado culpas ao Gildot... Afinal, o título de Notícias sobre Linux... e não só está lá apenas para enfeitar..."

    Não deitei a culpa ao Gildot mas aos tipos como tu que estão sempre mortinhos para morder em alguma coisa. Emrelação ao título: "Notícias sobre Linux... e não só¨ Representa isso mesmo e não só.

    Futuramente não irei propor artigos como este se é isto que queres ouvir va que alguem caia na tentação de aceita-lo *g*

     
    Re:mais um... (Pontos:1)
    por RaTao em 01-10-01 3:03 GMT (#27)
    (Utilizador Info)
    Esperava que alguem com mais experiencia do que eu pudesse me dar uma pista. Ja sabia que iam chover flames.

    ok, aqui temos a confirmação do próprio:
    f l a m e - b a i t e
    ou, por outras palavras: troll

    obrigado pelo esclarecimento.
    WHBT (o W é de "we", claro) :)

    Regards,
    Nuno Silva aka RaTao
    nada (Pontos:2)
    por André Simões em 29-09-01 21:47 GMT (#9)
    (Utilizador Info) http://hesperion.catus.net
    Nada, estou farto de fazer copy/paste, e nada, não crasha. Aliás, o KDE não me crasha desde a versão 1.2 (antes disso sim, era uma alegria). Tem outros problemas menores, mas crashar, não.
    Omnia aliena sunt: tempus tantum nostrum est. (Séneca)
    Hmmmm... (Pontos:2)
    por CrLf em 29-09-01 22:33 GMT (#10)
    (Utilizador Info) http://students.fct.unl.pt/~cer09566
    Por acaso não gostei, ao fim de uns quantos copy/pastes foi X foi tudo, e depois de arrancar o X novamente... crash...reset!
    Mas como há por aqui muita gente que não tem esse problema desconfio que a causa não deve ser o KDE...vou investigar...

    -- Carlos Rodrigues

    - "I think we can handle one little penguin!"
    - "No, Mr. Gates, your men are already dead!"
    Re:Hmmmm... (Pontos:2)
    por higuita em 30-09-01 0:03 GMT (#11)
    (Utilizador Info) http://raff.fe.up.pt/~eq92025
    vai uma aposta como e' as optimizacoes para x86 (sem ser 386)
    tenho reparado que estao novamente a aparecer problemas devido as optimizacoes dos processadores em varios programas, nao me admirava de ser mais um...


    Higuita
    Re:Hmmmm... (Pontos:2)
    por CrLf em 30-09-01 11:56 GMT (#15)
    (Utilizador Info) http://students.fct.unl.pt/~cer09566
    Não me parece, acho que o problema está mesmo no QT, porque os programas pure-QT também sofrem do mesmo problema. É engraçado ver que o GTK não sofre do mesmo problema simplesmente porque impõe um limite de 2047 caracteres nas entradas de texto simples (textentry, combobox...). Porque será que o QT não faz o mesmo?

    Se tiver tempo ainda vou chafurdar um bocado na source do QT 2.3.1.

    -- Carlos Rodrigues

    - "I think we can handle one little penguin!"
    - "No, Mr. Gates, your men are already dead!"
    Re:Hmmmm... (Pontos:1)
    por Lowgitek em 30-09-01 15:10 GMT (#18)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    FOi o que eu reparei tb porque tudo que seja GTK não acontece o problema maior que estou a usar o qt3.0 que o yast fez me o favor de fazer o update :) Mais uma prova que não podemos confiar muito nesses automatismos mais.. enfim a culpa e emparte minha que quiz ter menos trabalho :]

    Mas é bom saber que não acontece so comigo ja estava a ficar com trauma :)
    X 4.1.1 ?! (Pontos:2)
    por higuita em 30-09-01 0:17 GMT (#12)
    (Utilizador Info) http://raff.fe.up.pt/~eq92025
    desconfio que o problema deve ser no teu X...
    e' demasiado recente, tanto que ainda nao existe 8)

    move a dir .kde para .kde.bak, reinicia o X e tenta de novo

    Higuita
    Re:X 4.1.1 ?! (Pontos:1)
    por Lowgitek em 30-09-01 15:08 GMT (#17)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Queria dizer 4.1.0 r11

    É capaz mesmo de ser do x ou de algum problema relacionado com o QT ou as libs deste.

    O problema é idenpendente do user e em todas a s maquinas testadas tinham a mesma configuração ou seja ultimo kde ultimo x etc etc... nvidia

    Não tenho o core nem o log diz nada que se possa aproveitar.

    Re:X 4.1.1 ?! (Pontos:2)
    por higuita em 01-10-01 3:57 GMT (#28)
    (Utilizador Info) http://raff.fe.up.pt/~eq92025
    nesse caso desconfio de 2 coisas...

    o QT 3.0 (ja' que o kde 2.2.1 nao foi desenvolvido para esta versao da lib, logo e' normal que possam surgir problemas)
    claro que pode tambem ser daqueles bugs obscuros no kde/qt/x

    nvidia (se forem os driver fechados da nvidia)
    estes driver teem tido varios pequenos problemas, e este pode ser um deles (com tambem uma ajuda da QT ou do kde

    tenta com outro WM arrancar algo do kde e fazer o mesmo( se for abaixo entao deve ser do X, se apenas desaparece as aplicacoes kde, entao e' do KDE/qt)

    tenta tambem usar outro cliente de X que nao tenha uma nvidia (ou usa o framebuffer)
    (de for abaixo sabem que nao e' da nvidia e ate' podes saber se vai abaixo do lado do servidor (kde, QT, ou X) ou do cliente (apenas um problema do X)


    Higuita
    Re:X 4.1.1 ?! (Pontos:1)
    por Lowgitek em 01-10-01 18:42 GMT (#30)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    So acontece mesmo com o que seja a correr com o kde/qt todo o resto mesmo aplicações GTK a correr "sobre" o kde não fazem isso.

    Em relação ao driver da nvidia a ultima versão parece que esta a causar mais problemas que a resolver resolvi tira-la para estabilizar um pouco mais isso.

    Obrigado.
    Re:X 4.1.1 ?! (Pontos:2)
    por higuita em 02-10-01 23:54 GMT (#33)
    (Utilizador Info) http://raff.fe.up.pt/~eq92025
    o que eu queria mais dizer era que quando corres o kde como WM, se ele crasha o X fecha

    logo usando outro WM e usando depois aplicacoes KDE ficas a saber se e' o kde que crasha e fecha o X ou se e' mesmo o X que crasha e leva claro tudo atras (e claro, com uma ajuda o kde, como ja' foi provado)
    o kde pode estar "apenas" a enviar algo que o X nao gosta...

    acho um pouco estranho o KDE crashar e levar o X junto, o X deve e' fechar devido a saida do WM (ainda que forcada)


    Higuita
    Log do erro (Pontos:1)
    por Lowgitek em 01-10-01 18:51 GMT (#31)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Visto algumas pessoas terem reclamado e com razão da não inclusão de um log de qualquer coisa palpavel ai vai um que pode de certa forma ser util...

    startx > error.log (...)

    XFree86 Version 4.1.0 / X Window System
    (protocol Version 11, revision 0, vendor release 6510)
    Release Date: 2 June 2001
            If the server is older than 6-12 months, or if your card is
            newer than the above date, look for a newer version before
            reporting problems. (See http://www.XFree86.Org/FAQ)
    Build Operating System: SuSE Linux [ELF] SuSE
    Module Loader present
    (==) Log file: "/var/log/XFree86.0.log", Time: Mon Oct 1 19:45:13 2001
    (==) Using config file: "/etc/X11/XF86Config"
    Markers: (--) probed, (**) from config file, (==) default setting,
                      (++) from command line, (!!) notice, (II) informational,
                      (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) ServerLayout "Layout[all]"
    (**) |-->Screen "Screen[0]" (0)
    (**) | |-->Monitor "Monitor[0]"
    (**) | |-->Device "Device[0]"
    (**) |-->Input Device "Keyboard[0]"
    (**) XKB: keycodes: "xfree86"
    (**) XKB: rules: "xfree86"
    (**) XKB: model: "pc104"
    (**) XKB: layout: "pt"
    (**) |-->Input Device "Mouse[1]"
    (WW) The directory "/usr/X11R6/lib/X11/fonts/latin2/75dpi" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/latin2/100dpi" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/latin7/75dpi" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/ucs/misc" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/hellas/misc" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/hellas/75dpi" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/hellas/100dpi" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/hellas/Type1" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/japanese" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/baekmuk" does not exist.
            Entry deleted from font path.
    (WW) The directory "/usr/X11R6/lib/X11/fonts/xtest" does not exist.
            Entry deleted from font path.
    (**) FontPath set to "/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/local,/usr/X11R6/lib/X11 /fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100d pi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11 /fonts/Speedo,/usr/X11R6/lib/X11/fonts/PEX,/usr/X11R6/lib/X11/fonts/cyrillic,/usr/X11R6/li b/X11/fonts/latin2/misc,/usr/X11R6/lib/X11/fonts/latin2/Type1,/usr/X11R6/lib/X11/fonts/kwi ntv,/usr/X11R6/lib/X11/fonts/truetype,/usr/X11R6/lib/X11/fonts/uni,/usr/X11R6/lib/X11/font s/ucs/75dpi,/usr/X11R6/lib/X11/fonts/ucs/100dpi,/usr/X11R6/lib/X11/fonts/CID"
    (**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
    (**) ModulePath set to "/usr/X11R6/lib/modules"
    (--) using VT number 7

    (II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
    (II) Module bitmap: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/libpcidata.a
    (II) Module pcidata: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 0.1.0
    (II) Loading /usr/X11R6/lib/modules/libscanpci.a
    (II) Module scanpci: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 0.1.0
    (II) Unloading /usr/X11R6/lib/modules/libscanpci.a
    (--) PCI: (0:13:0) BrookTree unknown chipset (0x036e) rev 2, Mem @ 0xdd000000/12
    (--) PCI:*(1:0:0) NVidia Riva Ultra 64 rev 21, Mem @ 0xda000000/24, 0xd8000000/25
    (II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
    (II) Module dbe: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
    (II) Module type1: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
    (II) Module speedo: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
    (II) Module extmod: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
    (II) Module freetype: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.1.9
    (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
            compiled for 4.0.2, module version = 1.0.1541
    (II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
    (II) Module nvidia: vendor="NVIDIA Corporation"
            compiled for 4.0.2, module version = 1.0.1541
    (II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
    (II) Module mouse: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, RIVA TNT2 Ultra,
            RIVA TNT2 Vanta, RIVA TNT2 M64, RIVA TNT2 0x002E, RIVA TNT2 0x002F,
            RIVA Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX,
            GeForce2 MX 100/200, GeForce2 Go, GeForce2 MXR, GeForce2 GTS,
            GeForce2, GeForce2 Ultra, Quadro2 Pro, GeForce3, GeForce3, GeForce3,
            Quadro DCC
    (--) Assigning device section with no busID to primary device
    (--) Chipset RIVA TNT2 M64 found
    (II) Loading /usr/X11R6/lib/modules/libvgahw.a
    (II) Module vgahw: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 0.1.0
    (**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
    (==) NVIDIA(0): RGB weight 565
    (==) NVIDIA(0): Default visual is TrueColor
    (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    (--) NVIDIA(0): Linear framebuffer at 0xD8000000
    (--) NVIDIA(0): MMIO registers at 0xDA000000
    (--) NVIDIA(0): VideoRAM: 32768 kBytes
    (--) NVIDIA(0): Display Device 0: maximum pixel clock at 8 bpp: 300 MHz
    (--) NVIDIA(0): Display Device 0: maximum pixel clock at 16 bpp: 300 MHz
    (--) NVIDIA(0): Display Device 0: maximum pixel clock at 32 bpp: 250 MHz
    (II) Loading /usr/X11R6/lib/modules/libddc.a
    (II) Module ddc: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) NVIDIA(0): Monitor[0]: Using hsync range of 30.00-70.00 kHz
    (II) NVIDIA(0): Monitor[0]: Using vrefresh range of 50.00-100.00 Hz
    (II) NVIDIA(0): Clock range: 12.00 to 300.00 MHz
    (II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
    (II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
    (**) NVIDIA(0): Validated modes for Display Device 0:
    (**) NVIDIA(0): Mode "1024x768": 93.0 MHz, 68.0 kHz, 84.7 Hz
    (**) NVIDIA(0): Mode "640x480": 28.0 MHz, 32.4 kHz, 64.6 Hz
    (**) NVIDIA(0): Mode "800x600": 43.7 MHz, 40.7 kHz, 65.1 Hz
    (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
    (--) NVIDIA(0): Display dimensions: (32, 24) cm
    (--) NVIDIA(0): DPI set to (81, 81)
    (II) Loading /usr/X11R6/lib/modules/libfb.a
    (II) Module fb: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/libxaa.a
    (II) Module xaa: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 1.0.0
    (II) Loading /usr/X11R6/lib/modules/libramdac.a
    (II) Module ramdac: vendor="The XFree86 Project"
            compiled for 4.0.3, module version = 0.1.0
    (==) NVIDIA(0): Write-combining range (0xd8000000,0x2000000)
    (II) NVIDIA(0): Setting mode "1024x768"
    (II) NVIDIA(0): Using XFree86 Acceleration Architecture (XAA)
            Screen to screen bit blits
            Solid filled rectangles
            Solid filled trapezoids
            8x8 mono pattern filled rectangles
            8x8 mono pattern filled trapezoids
            Indirect CPU to Screen color expansion
            Solid Lines
            Scanline Image Writes
            Offscreen Pixmaps
            Driver provided FillSolidRects replacement
            Driver provided FillSolidSpans replacement
            Driver provided FillMono8x8PatternRects replacement
            Driver provided ReadPixmap replacement
            Setting up tile and stipple cache:
                    16 128x128 slots
                    4 256x256 slots
    (==) NVIDIA(0): Backing store disabled
    (==) NVIDIA(0): Silken mouse enabled
    (**) NVIDIA(0): DPMS enabled
    (II) [GLX]: Calling GlxExtensionInit
    (II) [GLX]: associated 8 out of 8 GLX visuals
    (II) Keyboard "Keyboard[0]" handled by legacy driver
    (**) Mouse[1]: Protocol: "imps/2"
    (**) Mouse[1]: Core Pointer
    (==) Mouse[1]: Buttons: 3
    (**) Mouse[1]: ZAxisMapping: buttons 4 and 5
    (II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
    iceauth: creating new authority file /home/eagle/.ICEauthority
    DCOPServer up and running.
    Property 'Export' is defined multiple times (KOfficeFilterDialog)
    Property 'Import' is defined multiple times (KOfficeFilterDialog)

    Fatal server error:
    Caught signal 11. Server aborting

    When reporting a problem related to a server crash, please send
    the full server output, not just the last messages.
    This can be found in the log file "/var/log/XFree86.0.log".
    Please report problems to feedback@suse.de.

    xinit: connection to X server lost.
    kdeinit: Fatal IO error: client killed
    kdeinit: sending SIGHUP to children.
    kdeinit: sending SIGTERM to children.
    kdeinit: Exit.
    KLauncher: Exiting on signal 15
    kicker: sighandler called
    kicker: sighandler called
    ICE default IO error handler doing an exit(), pid = 6300, errno = 0

    log do xfree de vido a sua extenção pode ser visto caso alguem tenha interesse em: http://www.ideiasdigitais.co.pt/post/xfree.log

    Obrigado e desculpem pela extenção do post.


    Possível explicação - Request For Comments (Pontos:2)
    por CrLf em 02-10-01 14:58 GMT (#32)
    (Utilizador Info) http://students.fct.unl.pt/~cer09566
    Após uma troca de emails com alguém na Trolltech, o qual me diz que consegue fazer um paste de 32K de texto sem problemas, a hipótese é uma falha nos drivers da nvidia (espanto dos espantos) uma vez que ele está a usar uma matrox.

    Por isso gostaria de saber se quem já conseguiu crashar o X com esta habilidade está a usar outros drivers que não os drivers binários da Nvidia e se os outros que não estão conseguem reproduzir o bug (basta fazer paste de 6Kb+ de texto para um QLineEdit).

    -- Carlos Rodrigues

    - "I think we can handle one little penguin!"
    - "No, Mr. Gates, your men are already dead!"

     

     

    [ Topo | Sugerir artigo | Artigos anteriores | Sondagens passadas | FAQ | Editores | Preferências | Contacto ]