gildot

Topo
Sobre
FAQ
Tópicos
Autores
Preferências
Artigos
Sondagens
Propor artigo


8/3
gildicas
9/30
jobs
10/9
perguntas
10/25
press

 
Primeiras impressões sobre o KDE 2.2
Contribuído por BladeRunner em 15-08-01 23:51
do departamento save-the-endangereoused-gnome-species
KDE Lowgitek escreve "Viva!
A primeira impressão que obtenho a usar esta magnifica peça de software é WOOOW ... Sim Sr. ... os Srs. Developpers estão de parabens o Konqueror ta melhor / rápido / leve que nunca. O painel de controlo ganha uma nova dimensão muito mais integrado enfim nunca vi kde melhor que este tem quase tudo que é preciso ter e o kmail finalmente funciona como deve de ser.
A par de alguns azares na instalação o sistema agora corre que nem um coelho.

Para aqueles que ainda não o tem e que gostam do KDE ou que olham ainda com algum descrédito para o mesmo não percam tempo e arranjam já uma cópia."

Apanhados na rede | Suporte para Linux Mandrake em IRC 24/7  >

 

gildot Login
Login:

Password:

Referências
  • Mais acerca KDE
  • Também por BladeRunner
  • Esta discussão foi arquivada. Não se pode acrescentar nenhum comentário.
    A objectividade do costume ... (Pontos:0, Engraçado)
    por Anonimo Cobarde em 16-08-01 14:21 GMT (#1)
    ... em reviews do KDE :)
    It rules. :) (Pontos:2)
    por Dehumanizer em 16-08-01 15:01 GMT (#2)
    (Utilizador Info)
    Está mesmo muito bom... estou a usar agora. :)

    Só uma questão: alguém tem problemas com esta versão, com o Konqueror a aceder a sites c/ SSL, através de um proxy? Parece-me que ele faz o pedido ao proxy incorrectamente... Isto não acontecia na última versão.

    Por outro lado, em www.opera.com/linux, saiu há dias o Opera 5.05, que já suporta plugins de Netscape (em particular, Java e Flash), e que continua a ser muito mais rápido e leve do que qq outro browser em Linux. :)


    "Mount up, you dogs! It is time for the hordes of General Fang to strike terror to those who were foolish enough to survive my missile attack!"
    Re:It rules. :) (Pontos:2)
    por Cyclops em 16-08-01 16:02 GMT (#3)
    (Utilizador Info)
    e que continua a ser muito mais rápido e leve do que qq outro browser em Linux

    E que continua a ser o menos Livre de todos os browsers que correm em Linux.

    Eu ca continuo fiel ao gecko, seja em Mozilla, galeon, konqueror, etc, desde que usem uma aplicacao decente:)

    Hugs, Cyke
    Re:It rules. :) (Pontos:2)
    por Dehumanizer em 16-08-01 17:37 GMT (#4)
    (Utilizador Info)

    E que continua a ser o menos Livre de todos os browsers que correm em Linux.

    Esse e o Netscape. Mas tens razão. De certa forma é pena... tenho a certeza de que muita gente aqui não liga minimamente ao facto de um software ser ou não livre, mas eu ligo.

    Mas é um facto que ninguém ainda conseguiu fazer um browser (para Linux, Windows ou qq outro SO) tão leve e eficiente como o Opera. Nesse aspecto, estão anos-luz à frente dos outros.

    O Konqueror está quase lá, mas esta questão do proxy por https estraga tudo... :( O Mozilla, como os próprios autores já admitiram, não vai diminuir de tamanho, contam é com que os CPUs e memória fiquem tão baratos que a questão acabe por ser irrelevante. Num Athlon a 1 Ghz com 512 Mb RAM (não, não tenho um... :( ), o Mozilla porta-se lindamente, nem parece mais "lento" ou "pesado" do que os outros. Num P3-500 com 128Mb RAM (como tenho no trabalho)... bem, é preciso ter paciência. Muuuuuita paciência. Ou usar o Opera.


    "Mount up, you dogs! It is time for the hordes of General Fang to strike terror to those who were foolish enough to survive my missile attack!"

    Re:It rules. :) (Pontos:1)
    por Lowgitek em 16-08-01 19:17 GMT (#6)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Em relação ao konqueror a única coisa que realmnete me irritava era o suporte ao java parece estar melhor nessa versão ao menos ja vejo as coisas a funcionarem. Em rela.ao ao Kmail já era hora de porem suportem ao html ....
    Re:It rules. :) (Pontos:1)
    por urgan em 17-08-01 0:46 GMT (#9)
    (Utilizador Info)
    O kmail tem suporte para html. Acho é que está desligado por defeito (e ainda bem, os web-bugs são uma praga) .
    Re:It rules. :) (Pontos:1)
    por Lowgitek em 17-08-01 1:11 GMT (#10)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    Agora tem realmente como deve de ser anteriormente tinha algo parecido com suportar...
    Re:It rules. :) (Pontos:1)
    por BlueNote em 17-08-01 13:07 GMT (#13)
    (Utilizador Info)
    eu também ligo... e também não gosto de usar software pirata e de certeza que não vou mandar dólares à OperaSoft... warez basta o do mundo windows...
    Re:It rules. :) (Pontos:2)
    por Dehumanizer em 17-08-01 13:24 GMT (#15)
    (Utilizador Info)
    Desde a versão 5.x que não precisas de lhes mandar dólares... é adware. Tem um banner, mas não chateia muito, desde o primeiro dia que não reparo nele. :) Podes mandar-lhes dólares para tirar o banner, o que até sou capaz de fazer... believe it or not, acho que eles merecem. Sim, eu sei que parece contraditório, mas...


    "Mount up, you dogs! It is time for the hordes of General Fang to strike terror to those who were foolish enough to survive my missile attack!"
    Re:It rules. :) (Pontos:2)
    por Cyclops em 17-08-01 13:16 GMT (#14)
    (Utilizador Info)
    Tive durante muitos meses um p3 a 500 com 128 megas de memoria, e ja desde antes da famosa 0.6 do mozilla que este e o meu browser por excelencia. Desde entao so tem melhorado.

    Nao consigo compreender como e que (apesar de ser muito) os 30M de memoria que ele usa, dos quais cerca de metade e partilhada (e por isso potencialmente gasta menos memoria) o podes achar muito lento. Se calhar e mais os applets todos que usas.

    E se usas kde, e natural que o opera pareca mais leve do que o mozilla, dado que este por default usa gtk penso (eu de que), e o opera usa a qt. Tendo um desktop com base na qt, uma aplicacao que usa a qt parece muito mais leve que uma que usa a gtk, dado que para alem do tk grafico que ja usas, ainda tem de carregar mais um. A memoria soma-se... e torna-se mais complicado gerir. Se queres usar o mozilla, talvez nao precises de tanta paciencia se usares um desktop baseado em gtk.

    Hugs, Cyke

    PS: o Konqueror pode usar o gecko como renderer, e nao tens o peso da interface grafica do mozilla, a mesmissima coisa com o galeon, em gnome.
    A memória não é problema grave (Pontos:1)
    por k em 18-08-01 15:04 GMT (#22)
    (Utilizador Info)
    Todos os meus problemas actuais de performance fossem memória. Ao preço que ela está nem dá para chatear muito.

    Espero não ser muito chacinado por este meu post, pois é claro que a memória é para ser bem usada, mas com pequenos luxos.
    --
    k

    Re:It rules. :) (Pontos:2)
    por CrLf em 16-08-01 22:30 GMT (#7)
    (Utilizador Info) http://students.fct.unl.pt/~cer09566
    (...)Eu ca continuo fiel ao gecko, seja em Mozilla, galeon, konqueror, etc, desde que usem uma aplicacao decente:)(...)

    O konqueror não usa o gecko, usa o KHTML.

    -- Carlos Rodrigues

    - "I think my men can handle one little penguin!"
    - "No, Mr. Gates, your men are already dead!"
    Re:It rules. :) (Pontos:1)
    por Lowgitek em 16-08-01 19:15 GMT (#5)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    O +unico problema que tive foi com o som que ainda não consegui resolver mas por erro meu que ao inves de fazer o upgrade dos packages quando dei por mim estava a reinstala-los :( ... shame on me
    Fora isso sem nada a assinalar
    Re:It rules. :) (Pontos:2)
    por TarHai em 17-08-01 12:55 GMT (#12)
    (Utilizador Info) http://www.dilbert.com
    Ummm... o botao de reply do gil parece nao funcionar... estranho...

    Tirando isso, o KDE 2.2 e um upgrade a "open source": Menos bloat e mais funcionalidade.


    ---
    kdesupport (Pontos:2)
    por Gamito em 17-08-01 0:19 GMT (#8)
    (Utilizador Info)
    Viva!

    Ainda não tive tempo nem de fazer o download, mas andei a dar uma vista de olhos nos pacotes e reparei que falta o tradicional kdesupport

    Wass up?

    Mário Gamito
    educação, ensino
    Re:kdesupport (Pontos:1)
    por Castanheiro em 17-08-01 20:48 GMT (#21)
    (Utilizador Info) http://students.fct.unl.pt/users/fdc10056
    O kdesupport agora vem incluido ou no kdebase ou no kdelibs, ou já não vem em lado nenhum pq as libs q ele trazia já eram fornecidas por todas as distribuições actuais. Fui muito conclusivo não fui? :-)
    Eu lembro-me de ter visto o assunto discutido nas mailinglists, mas não dei muita importância.
    QA (Pontos:2)
    por chbm em 17-08-01 14:14 GMT (#16)
    (Utilizador Info) http://chbm.nu/
    O QA do kde continua um espectaculo. Os builds para RH7 não instalam em RH7 e precisam de updates distribuidos pelo pessoal do kde que também não instalam em RH7. Andam a fazer o outsourcing dos builds à Mandrake ? :)
    Re:QA (Pontos:2)
    por CrLf em 17-08-01 14:35 GMT (#17)
    (Utilizador Info) http://students.fct.unl.pt/~cer09566
    O pessoal do kde so distribui as sources, os pacotes binários são da responsabilidade das distribuições ou de quem quer que queira fazer pacotes.
    O problema dos pacotes para RedHat 7.x é que requerem a instalação de quase metade da beta.
    Vê se não te falta nenhum pacote da directoria non-kde (é que eles parece que aparecem do nada).

    -- Carlos Rodrigues

    - "I think my men can handle one little penguin!"
    - "No, Mr. Gates, your men are already dead!"
    Re:QA (Pontos:2)
    por TarHai em 17-08-01 18:19 GMT (#18)
    (Utilizador Info) http://www.dilbert.com
    Eu tambem tive de fazer alguns updates a minha mandrake 8.0. O unico pacote q tive de ir buscar a beta foi um libpcre*.

    A meio, perdi a paciencia com o rpmdrake e companhia (nao sei porque cedo a esses masoquismos automatizados), foi com rpm -Uvh --force --nodeps da tralha toda.

    Tive sorte porque parece estar tudo a funcionar bem.

    ---
    Re:QA (Pontos:1)
    por Lowgitek em 17-08-01 18:41 GMT (#19)
    (Utilizador Info) http://www.ideiasdigitais.co.pt
    e por isso que gosto do suse foi so corre o yast e la estavs :) instalado .... :) claro so me lembrei disso depois de ter feito asneirada :) foi o tal U que m lembrei de por um i que completou a cena que faltava. A par disso a suse foi uma das primeiras a ter aquilo no site deles disponivel e no meu sistema nao precisei de mais nada senão o os packages do kde
    Re:QA (Pontos:1)
    por Tuaregue em 18-08-01 23:40 GMT (#23)
    (Utilizador Info)
    Eu também tenho o mandrake 8.0 e não tive problemas nenhuns de maior no update do Kde a não ser a quando do 1º update que me disse que já estava instalado, mas como dizes não á nada como o rpm -Uvh --force --nodeps, para resolver o assunto.
    Re:QA (Pontos:2)
    por chbm em 17-08-01 19:17 GMT (#20)
    (Utilizador Info) http://chbm.nu/
    > O pessoal do kde so distribui as sources, os pacotes binários são da responsabilidade das distribuições ou de quem quer que queira fazer pacotes.

    Tão no kde.org.

    > O problema dos pacotes para RedHat 7.x é que requerem a instalação de quase metade da beta.

    Tradução, foram feitos por idiotas. Segundo o README os pacotes devem instalar bem em 7.0 e 7.1 o que quer dizer que eles não sabem onde estão a fazer os builds.

    > Vê se não te falta nenhum pacote da directoria non-kde (é que eles parece que aparecem do nada).

    São esses que não instalam para começar.

    Um rpm --force --nodeps depois descobri que instalar o theme BeOS do Gtk+ empandeira de tal modo o KDE que deixa de arrancar. :)
    serei só eu? (Pontos:2)
    por André Simões em 19-08-01 0:58 GMT (#24)
    (Utilizador Info) http://hesperion.catus.net
    Bom, ao fim de quase 72 horas tenho o meu kde 2.2 a funcionar (até ver). Começo a ficar assustado, ao ver toda a gente dizer que correu tudo bem, que está tudo a funcionar às mil maravilhas, etc etc., e para mim foi uma odisseia. Nunca tive qualquer dificuldade em instalar o kde, e uso-o desde as primeiras releases. Desta vez porém, nada deu certo.
    Puxei os rpms para redhat 7.1. A aventura começou com as dependências... fui obrigado a fazer upgrade a boa parte do sistema, e alguns rpms foram difíceis de arranjar (só tarde de mais me lembrei de espreitar a insuspeita directoria non-kde, no ftp do kde. Burrice minha, mas podiam ter posto um nome mais exacto à directoria).
    Após ultrapassada a barreira das dependências, começou o esforço para pôr aquilo a correr pela primeira vez. Crashes sobre crashes, só ao fim de algumas reiniciliazações do X e algumas desinstalações e reinstalações dos rpms consegui correr o bicho pela primeira vez, e a coisa foi ao lugar... pensava eu!
    Estava eu todo contente a pensar que finalmente estava tudo bem, e eis que nem konqueror nem file manager, nada funciona. Lembrei-me de, com o mozilla, ir ao dot.kde.org, ver se alguém padecia do meu mal. Ao que parece a coisa lá por fora também não corre pelo melhor. De um post tirei a ideia de apagar a dir .kde , de modo a ele criar uma nova (de qualquer forma ele tinha apagado tudo o que eu lá tinha, sem pedir autorização...).
    Hurra! o konqueror já funcionava! Só que, após uma reinicialização do sistema, deixou de funcionar... Apaguei de novo a .kde, e passou a funcionar de novo. Portanto, só funcionava à primeira!
    Enchi-me de paciência, e comecei a apagar um subdirectoria da .kde de cada vez, a ver qual poderia ser a origem do mal. Depois de muitos rm -fr e ctrl-alt-backspace lá consegui - espero! - ter isto a funcionar aparentemente bem. Qual a dir que originava o problema? Nem sei, às tantas já ia apagando maquinalmente...

    Em jeito de conclusão: é pena que seja necessário todo este esforço, que se perca quase 3 dias para pôr este kde a funcionar (aparentemente) em pleno. Talvez o problema seja meu, talvez do meu pc... mas duvido. Já uso kde praticamente desde que surgiu, nunca tive quaisquer problemas... E uma vista de olhos por algumas listas, e mesmo aqui, permitem ver que afinal o problema não é meu.

    P.S.: Senhores, até me dei à pachorra de compilar a source, depois de ler alguns posts no dot.kde.org dizendo que "o problema é dos rpms, compilando a source não há problema". E nem assim...


    Omnia aliena sunt: tempus tantum nostrum est. (Séneca)

    Re:serei só eu? (Pontos:2)
    por grumbler em 19-08-01 6:26 GMT (#25)
    (Utilizador Info)
    Infelizmente não foste só tu que teve esse problema. Este bug do konqueror também deparei no portátil, e exactamente com o mesmo comportamento. Remover a directoria .kde resolveu uma vez, mas á segunda, o konqueror voltou a engasgar e o kdesktop fica marado quando faço alt+f2 e depois digito lá um URL qualquer. Como não tenho pachorra para andar a remover directorias e a copiar coisas antigas (preciso das minhas configurações antigas, muito obrigado :-( ) deixei tudo como está até descobrir qual a solução.

    Por outro lado no meu computador de casa não tive problemas nenhuns, mas neste caso foi sempre compilado á mão.. suspeito que o problema seja de estar a fazer um upgrade em cima de versões beta, mas é de facto um bug chato, especialmente pq o konqueror não dá nenhuma pista sobre o motivo de estar a engasgar.. mesmo um strace konqueror não é lá muito elucidativo infelizmente.. quanto muito dá para perceber que aquilo pendura depois de tentar escrever para o kded. Enfim, é pena, porque de facto a versão 2.2 quando funciona (como no meu computador de casa) vale mesmo a pena.

    --
    What, Me Worry?

    Re:serei só eu? (Pontos:2)
    por chbm em 20-08-01 9:08 GMT (#26)
    (Utilizador Info) http://chbm.nu/
    Nota o meu rant QA do kde. Poupava-te o trabalho :)
    Re:serei só eu? (Pontos:2)
    por André Simões em 20-08-01 20:12 GMT (#27)
    (Utilizador Info) http://hesperion.catus.net
    erm pois, realmente escrevi aquilo de rajada, sem ver se havia mais posts sobre o assunto :\
    Omnia aliena sunt: tempus tantum nostrum est. (Séneca)

     

     

    [ Topo | Sugerir artigo | Artigos anteriores | Sondagens passadas | FAQ | Editores | Preferências | Contacto ]