gildot

Topo
Sobre
FAQ
Tópicos
Autores
Preferências
Artigos
Sondagens
Propor artigo


8/3
gildicas
9/30
jobs
10/9
perguntas
10/25
press

 
XFree86 Release 4.4.0
Contribuído por BladeRunner em 04-03-04 16:20
do departamento das-releases
X racme escreve "Saiu no dia 29 de Fevereiro a ultima versao estavel da serie 4 do projecto XFree86. De salientar que o XFree86 4.4.0 foi lançado para 17 plataformas.
Algumas das novidades presentes nesta nova versao, alem da correcao de bugs, actualizacoes de segurança e melhorias do Xterm, inclui o suporte para IPV6. Re-escrita do driver da NVIDIA 'nv', bem como suporte para os chips NV36, GeForce FX5700 e NV38, GeForce FX5900. Melhor suporte para GFXs SYS, Intel e motherboards com placas graficas bultin baseadas em chipsets da VIA.
Mais suporte e estabilidade para MACOSx e sistemas operativos GNU/HURD. Actualizacao do FreeType2, e do backend FreeType a nivel do servidor XFree86.
De salientar ainda a possibilidade de a partir da versao 4.4.0 nao ser necessario especificar um ficheiro de configuracao (XFConfig) para sistemas operativos baseados em Linux ou FreeBSD."

PlugIn Magazine | Microsoft "empresta" $86 milhões à SCO  >

 

gildot Login
Login:

Password:

Referências
  • Linux
  • Intel
  • XFree86 4.4.0
  • Mais acerca X
  • Também por BladeRunner
  • Esta discussão foi arquivada. Não se pode acrescentar nenhum comentário.
    boicote (Pontos:2)
    por moonrider em 04-03-04 17:13 GMT (#1)
    (Utilizador Info) http://127.0.0.1
    Não achem esquisito se a vossa distribuição favorita não tiver esta nova versão, nem fiquem à espera disso enquanto a licença não for alterada... Se querem mesmo as novas versões, façam download da versão mais adequada e instalem ! Podem também reclamar no forum... pode ser que alguém vos dê ouvidos...
    Re:boicote (Pontos:2)
    por racme em 04-03-04 18:19 GMT (#2)
    (Utilizador Info) http://www.guildsoftware.com/download.html/
    Podem também reclamar no forum...

    reclamar porque? :>

    s/XFConfig/XF86Config



    We're coming - you're leaving - and don't let the door hit you on your way out! -- jfk
    Re:boicote (Pontos:2, Esclarecedor)
    por Manuel em 05-03-04 3:06 GMT (#3)
    (Utilizador Info) http://sindominio.net/~manuel/
    não lhe irá reclamar que lhe devolvam o dinheiro, é claro, mas pode ir reclamar para que lhes volva o sentidinho e volvam à velha licença. esta divisão é grave para o software livre (ou open source..), e embora tivessem a razão (que tb não me parece), tal como vai a coisa não parece que esse projecto tenha muito futuro.

    ora, eu também acho que se eles ainda não viram claro isso com todos os problemas e debates que já causaram, não adianta fazê-lo agora nesse seu forum.

    ponhamos, então, uma vela a Deus (e outra ao Demo, que não se zangue!), e vamos ver se arranjamos algo :P

    --
    Pela ribeira do rio cantando
    ia la virgo d'amor: quen amores
    à como dormirá, ai bela frol!
    Re:boicote (Pontos:2)
    por Cyclops em 05-03-04 8:27 GMT (#4)
    (Utilizador Info)
    Há alternativas, que agora vão ganhar muito mais força, como por exemplo o xserver do freedesktop.org ou o xouvert (que acho que têm uma relação muito intima)
    EGCS (Pontos:2)
    por CrLf em 05-03-04 23:22 GMT (#19)
    (Utilizador Info) http://crodrigues.webhop.net
    Nenhum desses dois tem hipóteses. O Xserver do freedesktop.org é completamente experimental, tem uma API de drivers completamente diferente e o próprio Keith Packard diz que não está pronto para uso. O Xouvert parece estar em águas de bacalhau, portanto também não é alternativa.
    A verdadeira alternativa é o X.org (que está alojado no freedesktop.org), que fez um fork do 4.4rc2+qqcoisa.

    Eu gostaria de ver um apoio ao X.org, e a inclusão do seu Xserver nas distribuições, pois na prática seria uma continuidade do XFree86 (sem quebras de drivers nem nada) mas sem o David Dawes e outros que tais que nos últimos anos foram os responsáveis pela falta de abertura e lento progresso do XFree86.

    Resumindo, é preciso que aconteça ao Xfree86 o que aconteceu ao GCC com o EGCS...

    -- Carlos Rodrigues
    Re:boicote (Pontos:2)
    por Dehumanizer em 05-03-04 8:41 GMT (#5)
    (Utilizador Info) http://www.dehumanizer.com
    SSH comercial -> OpenSSH. Quem é que usa o primeiro?

    ipfilter -> pf. Alguém que pode usar o segundo pensa sequer no primeiro?

    Acho que aqui também é óbvio o que é que vai acontecer. A não ser que os outros core developers se unam para tirar de lá o "Mr. Ego".


    "It is every citizen's final duty to go into the tanks and become one with all the people."
    - Chairman Sheng-ji Yang, "Ethics for Tomorrow"
    Re:boicote (Pontos:1)
    por Perky_Goth em 05-03-04 13:52 GMT (#9)
    (Utilizador Info)
    acho que é mais ou menos assumido que com o sr Boies (Bowes?) muita gente já não quer saber da coisa...
    ---
    Trolls, nem respondam porque não vos ouço.
    Que Bush vos abençoe.
    Re:boicote (Pontos:2)
    por racme em 05-03-04 23:25 GMT (#20)
    (Utilizador Info) http://www.guildsoftware.com/download.html/
    das tres uma:

    - ou das gracas ao Bush pela brilhante campanha no iraque e estado da economia global, dai a tua sig

    - ou das gracas ao gates e ao magnifico contributo que este permite por ser o IE o 2º browser mais utilizado neste forum com 25% fugindo aos esmagadores 99% habituais em tudo o que contenha as palavras "intarweb" e "portugal" na mesma frase, e dai justificar a tua santa ignorancia. Ou pelos brilhantes BSODs, o bodybuild e as aulas de ginastica gratis que tens ao baixar 5 vezes por dia o braco para os reboots da praxe.

    - ou entao das gracas ao David Dawes pelo brilhante contributo e a possibilidade de escreveres "mal" o seu nome, em jeito de gozo, num ambiente de trabalho que e' suportado por extensoes e interfaces de programacao conhecidos, sobre uma rede transparente e standardizada, atraves de uma arquitectura em 2 camadas que permite agregar os teus perifericos baratuchos, adquiridos na esquina do teu bairro ou como oferta numa qualquer caixa de chocapicas, como seja um simples teclado pt, um rato sujo, com bolas e que caga mais merda que o teu gato ou uma qualquer placa grafica moddada com um waterblock sobre a gpu e uma typhoon cujos feixes azuis combinam de veras com esse bg de magic shrooms sacado da digital blasphemy...



    We're coming - you're leaving - and don't let the door hit you on your way out! -- jfk
    Re:boicote (Pontos:1)
    por Manuel em 05-03-04 14:55 GMT (#10)
    (Utilizador Info) http://sindominio.net/~manuel/
    respondendo um pouco a este e ao comentário de acima, bem sei que há alternativas, mas nem me parece que este caso seja comparável a esses que citas.

    eu não tenho medo de que vaiamos ficar sem janelinhas, mas XFree era uma instituição nisto, um dos componentes mais importantes de qualquer sistema de software livre (GNU/Linux, *BSDs, os "pequeninos" e os que estão em desenvolvimento) de uso para escritório. assim, os mais importantes podem ser:

    - kernel -> Linux|BSDs
    - sistema base -> GNU|BSDs
    - sistema de janelas -> XFree
    - escritório -> GNOME|KDE|outros-embora-menos-integrados

    para esse componente que se deixará de utilizar aparecerá outro com a mesma função, não tenho preocupação com isso, mas é uma pena que por picuinhices de colocar mais uma linha na licença quando leva tantos anos com a outra tenhamos que andar com estes problemas. é algo que provoca instabilidade, não é muito bom para uma estratégia expansiva do software livre (os rivais podem utilizar isto como exemplo para técnicas FUD), cria mais uma luta por causa de licenças (que a gente de fora valoriza quase sempre como coisa negativa), e ainda por cima anda a fazer perder o tempo e energias de muita gente para reconduzir a situação, criar forks, repetir código, perder algum outro, ...

    sim, talvez finalmente até se chegue a um modelo de desenvolvimento mais aberto desse componente que faça com que melhore o sistema inteiro, mas por enquanto isto não traz coisa boa para o software livre. sem contar com que por um tempo ficaremos sem saber qual é a alternativa, ou se os gajos recuam e voltam à velha licença, e ficamos na mesma.

    --
    Pela ribeira do rio cantando
    ia la virgo d'amor: quen amores
    à como dormirá, ai bela frol!
    Re:boicote (Pontos:2)
    por Dehumanizer em 05-03-04 17:56 GMT (#11)
    (Utilizador Info) http://www.dehumanizer.com
    Primeiro, um fork aqui não é assim tão grave. Eles podem simplesmente pegar no 4.3.0 ou até no 4.4.0-rc2 e trabalhar a partir daí. Foi o que aconteceu com o OpenSSH - pegou-se na última versão "livre", e trabalhou-se a partir daí, acrescentando a versão 2 do protocolo, e outras features que a versão oficial nem sequer tem.

    Quanto à licença, tu podes ver isso como uma questão de "uma linha na licença", mas o facto é que NINGUÉM está contente com a alteração - nem quem usa GPL, nem sequer quem usa BSDL.

    E volto a dizer o que já disse nas outras 2 threads: não se trata de "forçar" os tipos do XF86 a ter a licença que "nós queremos", trata-se, sim, de ser respeitador da mesma.

    Repara, a licença diz: "para distribuir este software, é preciso fazer A, B e C".

    O resto do mundo responde: "sorry, não queremos fazer C. Não querem voltar só a exigir A e B?"

    Os tipos dizem: "não, é mesmo A, B e C, dammit!"

    Resto do mundo: "OK, sendo assim, não vamos distribuir o vosso software, já que não estamos autorizados por vocês a fazê-lo sem fazer C, e não queremos fazer C. Have a nice day."

    É uma simples questão de respeitar as condições da licença.


    "It is every citizen's final duty to go into the tanks and become one with all the people."
    - Chairman Sheng-ji Yang, "Ethics for Tomorrow"
    Re:boicote (Pontos:2)
    por racme em 05-03-04 22:34 GMT (#17)
    (Utilizador Info) http://www.guildsoftware.com/download.html/
    Nao sei onde e' q tu, Dehumanizer, e o Manuel foram buscar a ideia de que os BSDs estao contra a nova licenca do XFree86 4.4.

    O Papa tambem nao aprova o uso do preservativo mas comparacoes a' parte nem, o Theo vive no vaticano, nem o OBSD esta na 2º posicao dos BSDs mais utilizados em plataformas x86



    We're coming - you're leaving - and don't let the door hit you on your way out! -- jfk
    Afinal qual é o problema ? (Pontos:1)
    por igod em 05-03-04 9:13 GMT (#6)
    (Utilizador Info)
    Alguém sabe explicar exactamente onde é que a nova licensa do xfree falha quanto à compatibilidade do GPL ? E porquê ? Será que há alternativa ?
    Re:Afinal qual é o problema ? (Pontos:3, Informativo)
    por jmce em 05-03-04 11:03 GMT (#8)
    (Utilizador Info) http://jmce.artenumerica.org/
    O Branden Robinson, que faz a manutenção das packages XFree86 no projecto Debian, fez uma análise das incompatibilidades.
    Re:Afinal qual é o problema ? (Pontos:2)
    por racme em 05-03-04 19:44 GMT (#12)
    (Utilizador Info) http://www.guildsoftware.com/download.html/

    > I have an interogation about the aim of this mail though. You are
    > clearly following up on a mail from forum@xfree86.org, but in this
    > response you don't CC them.

    The reason is simple; I'm not subsribed to the XFree86 forum list, and I
    generally try to avoid sending unsolicited mail to lists to which I
    don't subscribe.


    Interessante no minimo como e' que alguem que mantem a port do Xfree para debian, ja lancou patches e contributos para o projecto xfree86 recussa participar na mailling list publica do projecto que representa.
      Mais do que isso, baseia-se num post retirado dessa mesma mailling list, e chega a' brilhante conclusao, e e' esse o facto relevante aqui, de que a BSD license original existe desde a versao 3 no projecto XFREE86 mas nunca ate agora levantou problemas de incompatibilidade com GNU/GPL.

    E' caso para perguntar onde esta a coerencia? Acho bem que analisem e verifiquem o que e' incompativel com a sua licenca, agora dai a obrigar os outros a mudar porque satisfaz a sua agenda, bom cada um tire as suas conclusoes, e certamente que a minha nao sera fundamentada por um dos extremos desta questao, ie debian commiters.



    We're coming - you're leaving - and don't let the door hit you on your way out! -- jfk
    Re:Afinal qual é o problema ? (Pontos:2)
    por racme em 05-03-04 19:50 GMT (#13)
    (Utilizador Info) http://www.guildsoftware.com/download.html/
    Alguém sabe explicar exactamente onde é que a nova licensa do xfree falha quanto à compatibilidade do GPL ? E porquê ? Será que há alternativa ?

    A nova licenca nao e' incompativel com GPL. E' por isso que ninguem te consegue responder positivamente.

    Um software basaeado em GPL linkado ao XFree86 ou de que este seja derivado, so sera GPL-incompatible se ja anteriormente tiver quebrado a licenca GPL. Basta ler a nova lincenca para perceber o que la e' exigido.



    We're coming - you're leaving - and don't let the door hit you on your way out! -- jfk
    Re:Afinal qual é o problema ? (Pontos:2)
    por CrLf em 05-03-04 21:18 GMT (#15)
    (Utilizador Info) http://crodrigues.webhop.net
    A nova licenca nao e' incompativel com GPL.

    Há pessoas muito teimosas...

    -- Carlos Rodrigues
    Re:Afinal qual é o problema ? (Pontos:2)
    por racme em 05-03-04 22:25 GMT (#16)
    (Utilizador Info) http://www.guildsoftware.com/download.html/
    e outras muito ingenuas



    We're coming - you're leaving - and don't let the door hit you on your way out! -- jfk
    Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por McB em 05-03-04 10:00 GMT (#7)
    (Utilizador Info)
    Ora viva.
    Há alguém aqui que tenha uma Radeon Mobility 9600 da ATI?

    Pelo que estive a ver da documentação, não há suporte para esta placa, nem no XFree 4.4
    Alguém já experimentou o XFree86 4.4 com esta placa com sucesso (o que me acontece a mim é que fica seleccionado "Generic Vesa", já que o XFree não encontra nada melhor).

    Já me disseram que a ATI tem drivers para a 9600 que TAMBÉM parecem ser para a Mobility, mas não consegui instalar aquilo... (check here).

    Alguém com uma experiência semelhante ou com alguma dica interessante para o caso?

    Yours,
    McB!
    They told me it need Windows 95 or better, so I chose Linux
    Re:Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por nmarques em 05-03-04 20:37 GMT (#14)
    (Utilizador Info) http://www.the-kult.net/kampfhund/
    TEMOS PENA!... Vens agora com win-g-adapters... Usa nvidia ;)
    --
    With the lights out, it's less dangerous
    Re:Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por CrLf em 05-03-04 23:15 GMT (#18)
    (Utilizador Info) http://crodrigues.webhop.net
    Realmente a ATi foi em tempos o fabricante de chips gráficos que melhor suportava o Linux. Mas hoje conseguiram colocar-se na cauda...

    -- Carlos Rodrigues
    Re:Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por higuita em 06-03-04 1:02 GMT (#22)
    (Utilizador Info)

    Quando puderes usar drivers 3D livres nas nvidia's avisa!!

    ... TEMOS PENA!! ;)

    agora mais a serio:

    pelo menos podemos escolher entre drivers 2D bons e 3D satisfatorios e livres e 2D decentes e 3D bom, mas fechados

    quem tem nvidia pode escolher entre 2D muito foleiro e livre (vamos ver se com o 4.4.0 o 2D pelo menos fica minimamente aceitavel) e drivers 2D decentes e 3D bons mas fechados

    e todos sabem ( ou deviam saber) que drivers fechados podem sempre ser um risco de estabilidade, fica-se preso ao fabricante e as suas vontades (ou existencia) para actualizar os drivers para as ultimas versoes de kernel e corrigir bugs

    para alguns isto nao tem importancia, tal como muitos ainda usam o windows, para outros sabem que os drivers fechados sao apenas solucoes temporarias e que melhor e' investir em drivers livres e fabricantes que apoiem mais os drivers livres

    sao opcoes


    Higuita
    Re:Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por McB em 17-03-04 15:34 GMT (#23)
    (Utilizador Info)
    Sairam drivers novos da ATI que já funcionam.

    Agradeço toda a pena que tendes, mas podes usá-la com qualquer outro desgraçado cuja placa ainda não seja suportada! :P

    Yours,
    McB!
    They told me it need Windows 95 or better, so I chose Linux
    Re:Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por higuita em 06-03-04 0:34 GMT (#21)
    (Utilizador Info)
    se a ATI diz que suporta a 9600 mobility nos seus drivers, entao funciona...

    tens de te esforcar mais a instalar os drivers dele, le BEM a documentacao

    mas o X deve suportar pelo menos o 2D, sem ser em vesa framebuffer, tinha ideia que a parte 2D funcionava para tudas as radeon

    tenta o driver radeon...
    talvez brincando com os chipid's

    eu tenho de usar o chipid da 9000 (os outros tambem funcionam, mas teoricamente a 9000 e' a mais proxima da 9200, logo a mais indicada)

    # 7500
    # ChipID 0x5157
    # 9000
    # ChipID 0x4967
                    ChipID 0x4966
    # 9100 (serie 8500)
    # ChipID 0x514D
    # 9200
    # ChipID 0x5963

    isto sao ati desktop, mas para as mobility deve ser praticamente igual, apenas chipid's diferente talvez?

    http://dri.sourceforge.net/cgi-bin/moin.cgi/ATIRadeon

    3D provavelmente so' mesmo com os drivers da ATI

    Higuita
    Re:Suporte para ATI Radeon Mobility 9600 (Pontos:2)
    por McB em 18-03-04 14:27 GMT (#24)
    (Utilizador Info)
    Tinham um bug que fazia com que o driver não funciona em Athlon, mas já está resolvido!

    Yours,
    McB!
    They told me it need Windows 95 or better, so I chose Linux

     

     

    [ Topo | Sugerir artigo | Artigos anteriores | Sondagens passadas | FAQ | Editores | Preferências | Contacto ]